Generate new keysyms although profile is common
[platform/upstream/libxkbcommon.git] / packaging / libxkbcommon.spec
index 136f9cc..94cc05c 100644 (file)
@@ -21,6 +21,8 @@ BuildRequires:  python
 BuildRequires:  xkb-tizen-data
 %endif
 
+%global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
+
 %description
 Keyboard handling library using XKB data.
 
@@ -40,14 +42,12 @@ in %{name}.
 cp %{SOURCE1001} .
 
 # Generate tizen keymap header except common profile
-%if "%{?profile}" == "common"
-%else
 export TIZEN_PROFILE="%{?profile}"
+export TZ_SYS_RO_SHARE="%{TZ_SYS_RO_SHARE}"
 chmod a+x ./make_tizen_keymap.sh
 ./make_tizen_keymap.sh
 chmod a+x ./gen_tables.sh
 ./gen_tables.sh
-%endif
 
 %build
 %autogen --disable-static --disable-x11 --with-tizen-profile="%{?profile}"
@@ -56,6 +56,10 @@ chmod a+x ./gen_tables.sh
 %install
 %make_install
 
+#for license notification
+mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/license
+cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/%{TZ_SYS_RO_SHARE}/license/%{name}
+
 %post  -p /sbin/ldconfig
 
 %postun  -p /sbin/ldconfig
@@ -63,7 +67,7 @@ chmod a+x ./gen_tables.sh
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root)
-%license COPYING
+%{TZ_SYS_RO_SHARE}/license/%{name}
 %{_libdir}/libxkbcommon.so.0*
 
 %files devel