Implements WatchBase
[platform/core/appfw/widget-viewer.git] / packaging / libwidget_viewer.spec
index 7eaf189..839b04e 100644 (file)
@@ -13,7 +13,9 @@ Source1004: watch-control.manifest
 Source1005: frame-broker.manifest
 Source1006: frame-provider.manifest
 Source1007: watch-holder.manifest
-Source1008: ambient-viewer.manifest
+Source1008: watch-holder-base.manifest
+Source1009: ambient-viewer.manifest
+
 BuildRequires: cmake, gettext-tools, coreutils, edje-bin
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(aul)
@@ -61,6 +63,7 @@ cp %{SOURCE1005} .
 cp %{SOURCE1006} .
 cp %{SOURCE1007} .
 cp %{SOURCE1008} .
+cp %{SOURCE1009} .
 
 %build
 export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
@@ -195,12 +198,36 @@ Header & package configuration of watch-control
 %postun -n watch-control -p /sbin/ldconfig
 
 ################################################
+# libwatch_holder_base
+%package -n watch-holder-base
+Summary: APIs to control watch applications
+Version: 0.0.1
+License: Flora-1.1
+Group: Applications/Core Applications
+
+%description -n watch-holder-base
+A set of APIs to control watch applications
+
+%package -n watch-holder-base-devel
+Summary: APIs to control watch applications
+Group: Development/Libraries
+Requires: watch-holder-base
+
+%description -n watch-holder-base-devel
+Header & package configuration of watch-holder-base
+
+%post -n watch-holder-base -p /sbin/ldconfig
+%postun -n watch-holder-base -p /sbin/ldconfig
+
+################################################
 # libwatch_holder
 %package -n watch-holder
 Summary: APIs to control watch applications
 Version: 0.0.1
 License: Flora-1.1
 Group: Applications/Core Applications
+Requires: watch-holder-base
+
 
 %description -n watch-holder
 A set of APIs to control watch applications
@@ -329,6 +356,15 @@ Header & package configuration of ambient-viewer
 %{_libdir}/pkgconfig/watch-holder.pc
 %{_libdir}/libwatch-holder.so
 
+%files -n watch-holder-base
+%manifest watch-holder-base.manifest
+%license LICENSE.Flora-1.1 LICENSE.Apache-2.0
+%{_libdir}/libwatch-holder-base.so.*
+
+%files -n watch-holder-base-devel
+%{_includedir}/watch-holder-base/*.hh
+%{_libdir}/pkgconfig/watch-holder-base.pc
+%{_libdir}/libwatch-holder-base.so
 
 %files -n frame-broker
 %manifest frame-broker.manifest