[CVE-2018-10393] heap buffer overflow
[platform/upstream/libvorbis.git] / packaging / libvorbis.spec
index 9fe159d..b345c72 100644 (file)
@@ -1,17 +1,13 @@
 Name:           libvorbis
-Version:        1.3.3
+Version:        1.3.4
 Release:        0
-License:        BSD-3-Clause
+License:        BSD-2.0
 Summary:        The Vorbis General Audio Compression Codec
 Url:            http://www.vorbis.com/
-Group:          System/Libraries
-Source:         %{name}-%{version}.tar.bz2
+Group:          Multimedia/Audio
+Source:         %{name}-%{version}.tar.xz
 Source2:        baselibs.conf
-Patch1:         libvorbis-lib64.dif
-Patch2:         libvorbis-m4.dif
-Patch10:        libvorbis-pkgconfig.patch
-Patch11:        vorbis-fix-linking.patch
-Patch12:        vorbis-ocloexec.patch
+Source1001:     libvorbis.manifest
 BuildRequires:  fdupes
 BuildRequires:  libogg-devel
 BuildRequires:  libtool
@@ -29,7 +25,7 @@ libmatroska (matroska) can also be used.
 %package -n libvorbisenc
 
 Summary:        The Vorbis General Audio Compression Codec
-Group:          System/Libraries
+Group:          Multimedia/Audio
 
 %description -n libvorbisenc
 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
@@ -42,7 +38,7 @@ libmatroska (matroska) can also be used.
 %package -n libvorbisfile
 
 Summary:        The Vorbis General Audio Compression Codec
-Group:          System/Libraries
+Group:          Multimedia/Audio
 
 %description -n libvorbisfile
 Vorbis is a fully open, nonproprietary, patent-and-royalty-free, and
@@ -54,49 +50,38 @@ libmatroska (matroska) can also be used.
 
 %package devel
 Summary:        Include Files and Libraries mandatory for Ogg Vorbis Development
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 Requires:       glibc-devel
 Requires:       libogg-devel
-Requires:       libvorbis = %{version}
-Requires:       libvorbisenc = %{version}
-Requires:       libvorbisfile = %{version}
+Requires:       libvorbis = %{version}-%{release}
+Requires:       libvorbisenc = %{version}-%{release}
+Requires:       libvorbisfile = %{version}-%{release}
 
 %description devel
 This package contains all necessary include files and libraries needed
 to compile and develop applications that use libvorbis.
 
-%package doc
-Summary:        Documentation of Ogg/Vorbis library
-Group:          Documentation/Other
-BuildArch:      noarch
-
-%description doc
-This package contains documents for Ogg/Vorbis library, including the
-API reference.
-
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 # Fix optimization level
 sed -i s,-O20,-O3,g configure.ac
 
-autoreconf -fiv
-%configure --disable-examples --disable-static
-make %{?_smp_mflags}
+%autogen --disable-examples --disable-static
+%__make %{?_smp_mflags}
 
 %check
-make check
+%__make check
 
 %install
 %make_install
 mkdir -p %{buildroot}%{_docdir}/%{name}
 mv %{buildroot}%{_datadir}/doc/libvorbis-* %{buildroot}%{_docdir}/%{name}
 install -c -m 0644 doc/Vorbis_I_spec.* %{buildroot}%{_docdir}/%{name}
-# remove unneeded files
-find %{buildroot}%{_docdir}/ -empty -delete
-%fdupes -s %{buildroot}%{_docdir}
 
+%remove_docs
 
 %post  -p /sbin/ldconfig
 
@@ -111,27 +96,28 @@ find %{buildroot}%{_docdir}/ -empty -delete
 %postun -n libvorbisfile -p /sbin/ldconfig
 
 %files 
+%manifest %{name}.manifest
 %defattr(0644,root,root,0755)
+%license COPYING 
 %{_libdir}/libvorbis.so.0*
 
 %files -n libvorbisenc
+%manifest %{name}.manifest
 %defattr(0644,root,root,0755)
+%license COPYING 
 %{_libdir}/libvorbisenc.so.2*
 
 %files -n libvorbisfile
+%manifest %{name}.manifest
 %defattr(0644,root,root,0755)
+%license COPYING 
 %{_libdir}/libvorbisfile.so.3*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
-%doc COPYING AUTHORS README *.txt
+%license COPYING 
 %{_datadir}/aclocal/*.m4
 %{_includedir}/vorbis
 %{_libdir}/lib*.so
 %{_libdir}/pkgconfig/*.pc
-
-%files doc
-%defattr(-,root,root)
-%doc %{_docdir}/%{name}
-
-%changelog