Add a LICENSE.MIT file and it to the build spec.
[platform/upstream/libusb.git] / packaging / libusb.spec
old mode 100644 (file)
new mode 100755 (executable)
index 6835892..70a8026
@@ -3,7 +3,7 @@
 Name:           libusb
 Version:        1.0.21
 Release:        0
-License:        LGPL-2.1+
+License:        LGPL-2.1+, MIT
 Summary:        USB Library
 Url:            http://www.libusb.org/
 Group:          Base/Device Management
@@ -43,6 +43,9 @@ make %{?_smp_mflags}
 
 %install
 %make_install
+# usbhost_module
+mkdir -p %{buildroot}%{_prefix}/lib/udev/rules.d
+install -m 644 udev/99-usbhost.rules %{buildroot}%{_prefix}/lib/udev/rules.d/99-usbhost.rules
 
 %post  -p /sbin/ldconfig
 
@@ -51,12 +54,15 @@ make %{?_smp_mflags}
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root)
-%license COPYING
+%license LICENSE.LGPL-2.1+ LICENSE.MIT
 %{_libdir}/*.so.*
+# usbhost_module
+%{_prefix}/lib/udev/rules.d/99-usbhost.rules
 
 %files devel
 %manifest %{name}.manifest
 %defattr(-,root,root)
+%license LICENSE.LGPL-2.1+ LICENSE.MIT
 %{_includedir}/libusb-1.0
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc