Add a LICENSE.MIT file and it to the build spec.
[platform/upstream/libusb.git] / packaging / libusb.spec
old mode 100644 (file)
new mode 100755 (executable)
index 611b690..70a8026
@@ -1,7 +1,9 @@
+%define TIZEN_FEATURE_USBHOST_API on
+
 Name:           libusb
-Version:        1.0.19
+Version:        1.0.21
 Release:        0
-License:        LGPL-2.1+
+License:        LGPL-2.1+, MIT
 Summary:        USB Library
 Url:            http://www.libusb.org/
 Group:          Base/Device Management
@@ -10,7 +12,7 @@ Source1:        baselibs.conf
 Source1001:    libusb.manifest
 BuildRequires:  pkg-config
 BuildRequires:  systemd-devel
-%if "%{?profile}" == "mobile"
+%if %{?TIZEN_FEATURE_USBHOST_API} == on
 BuildRequires:  pkgconfig(dbus-1)
 %endif
 
@@ -33,7 +35,7 @@ cp %{SOURCE1001} .
 %build
 %reconfigure\
        --with-pic\
-%if "%{?profile}" == "mobile"
+%if %{?TIZEN_FEATURE_USBHOST_API} == on
        --enable-usbhost-api \
 %endif
        --disable-static
@@ -41,6 +43,9 @@ make %{?_smp_mflags}
 
 %install
 %make_install
+# usbhost_module
+mkdir -p %{buildroot}%{_prefix}/lib/udev/rules.d
+install -m 644 udev/99-usbhost.rules %{buildroot}%{_prefix}/lib/udev/rules.d/99-usbhost.rules
 
 %post  -p /sbin/ldconfig
 
@@ -49,12 +54,15 @@ make %{?_smp_mflags}
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root)
-%license COPYING
+%license LICENSE.LGPL-2.1+ LICENSE.MIT
 %{_libdir}/*.so.*
+# usbhost_module
+%{_prefix}/lib/udev/rules.d/99-usbhost.rules
 
 %files devel
 %manifest %{name}.manifest
 %defattr(-,root,root)
+%license LICENSE.LGPL-2.1+ LICENSE.MIT
 %{_includedir}/libusb-1.0
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc