Aarch64 build fix
[platform/upstream/libtool.git] / packaging / libtool.spec
index aa637e6..3d44e9e 100644 (file)
@@ -9,7 +9,7 @@ Requires:       automake > 1.4
 Requires:       tar
 Summary:        A Tool to Build Shared Libraries
 License:        GPL-2.0+
-Group:          Development/Tools/Building
+Group:          Development/Tools
 Version:        2.4.2
 Release:        0
 Requires:       libltdl = %{version}
@@ -17,6 +17,7 @@ Url:            http://www.gnu.org/software/libtool/
 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
 Source2:        baselibs.conf
 Source3:        libtool-rpmlintrc
+Source1001:    libtool.manifest
 Provides:       libltdl-devel
 # fedora name
 Provides:       libtool-ltdl-devel
@@ -27,31 +28,33 @@ architectures to build shared libraries in a generic fashion.
 
 %package -n libltdl
 Summary:        Libtool Runtime Library
-Group:          Development/Libraries/C and C++
+Group:          System/Libraries
 
 %description -n libltdl
 Library needed by programs that use the ltdl interface of GNU libtool.
 
 %prep
 %setup -q -n libtool-%{version}
+cp %{SOURCE1001} .
 
 %build
-./configure CFLAGS="$RPM_OPT_FLAGS" \
-   --prefix=/usr --infodir=%{_infodir} --libdir=%{_libdir}
+%configure
 # force rebuild with non-broken makeinfo
 rm -f doc/libtool.info
 make %{?_smp_mflags}
 
 
 %install
-%make_install
+make install DESTDIR=$RPM_BUILD_ROOT
 
 %post -n libltdl -p /sbin/ldconfig
 
 %postun -n libltdl -p /sbin/ldconfig
 
 %files
+%manifest %{name}.manifest
 %defattr(-, root, root)
+%license COPYING
 /usr/bin/libtool
 /usr/bin/libtoolize
 /usr/include/libltdl
@@ -66,6 +69,7 @@ make %{?_smp_mflags}
 /usr/share/libtool
 
 %files -n libltdl
+%manifest %{name}.manifest
 %defattr(-, root, root)
 %{_libdir}/libltdl.so.*