spec: Use %license macro to copy license
[platform/upstream/libtheora.git] / packaging / libtheora.spec
index cb0eef3..3a5a90b 100644 (file)
@@ -1,13 +1,14 @@
 Name:           libtheora
 Version:        1.1.1
 Release:        14
-License:        BSD-3-Clause
+License:        BSD-2.0
 Summary:        Free Video Codec
 Url:            http://www.theora.org/
 Group:          Multimedia/Video
 %define pkg_version %{version}
 Source:         %{name}-%{version}.tar.bz2
 Source2:        baselibs.conf
+Source1001:    libtheora.manifest
 BuildRequires:  gcc-c++
 BuildRequires:  libogg-devel
 BuildRequires:  libtool
@@ -34,6 +35,7 @@ to playback VP3 streams.
 
 %prep
 %setup -q -n %{name}-%{pkg_version}
+cp %{SOURCE1001} .
 
 %build
 ACLOCAL="aclocal -I m4" autoreconf -f -i
@@ -56,13 +58,15 @@ rm -rf %{buildroot}/%{_datadir}/doc/%{name}-%{version}/*
 %postun  -p /sbin/ldconfig
 
 %files
+%manifest %{name}.manifest
 %defattr(-,root,root)
-%doc COPYING LICENSE
+%license COPYING LICENSE
 %{_libdir}/libtheora.so.0*
 %{_libdir}/libtheoradec.so.1*
 %{_libdir}/libtheoraenc.so.1*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_includedir}/theora
 %{_libdir}/*.so