change the log macro at all files
[platform/core/uifw/libtbm.git] / packaging / libtbm.spec
index 069c1aa..2db1978 100644 (file)
@@ -1,9 +1,10 @@
 %bcond_with x
 %bcond_with wayland
-%bcond_with utest
+%define UTEST_PACKAGE 1
+%define UTEST_GCOV    0
 
 Name:           libtbm
-Version:        2.0.22
+Version:        2.5.0
 Release:        1
 License:        MIT
 Summary:        The library for Tizen Buffer Manager
@@ -18,10 +19,7 @@ BuildRequires:  pkgconfig(capi-base-common)
 BuildRequires:  pkgconfig(libpng)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(pixman-1)
-
-%if %{with utest}
-BuildRequires:  gtest-devel
-%endif
+BuildRequires:  gtest-devel 
 
 %description
 Description: %{summary}
@@ -37,6 +35,15 @@ The library for Tizen Buffer Manager.
 
 Development Files.
 
+%if "%{UTEST_PACKAGE}" == "1"
+%package utests
+Summary: Tizen Buffer Manager unit tests package
+Group: System/Libraries
+
+%description utests
+Test module for testing libtbm APIs
+%endif
+
 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
 
 %prep
@@ -46,24 +53,26 @@ cp %{SOURCE1001} .
 %build
 UTEST="no"
 
-%if %{with utest}
+%if "%{UTEST_PACKAGE}" == "1"
 UTEST="yes"
 %endif
 
+%if "%{UTEST_GCOV}" == "1"
+CFLAGS+=" -fprofile-arcs -ftest-coverage -DTIZEN_TEST_GCOV"
+CXXFLAGS+=" -fprofile-arcs -ftest-coverage -DTIZEN_TEST_GCOV"
+LDFLAGS+=" -lgcov"
+%endif
+
 %if %{with wayland}
-%reconfigure --prefix=%{_prefix} --with-tbm-platform=WAYLAND  --with-utest=${UTEST} \
+%reconfigure --prefix=%{_prefix} --with-tbm-platform=WAYLAND  --with-utests=${UTEST} \
             CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
 %else
-%reconfigure --prefix=%{_prefix} --with-tbm-platform=X11  --with-utest=${UTEST} \
+%reconfigure --prefix=%{_prefix} --with-tbm-platform=X11  --with-utests=${UTEST} \
             CFLAGS="${CFLAGS} -Wall -Werror" LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
 %endif
 
 make %{?_smp_mflags}
 
-%if %{with utest}
-make -C ut check
-%endif
-
 %install
 rm -rf %{buildroot}
 %make_install
@@ -90,9 +99,6 @@ rm -f %{_unitdir_user}/basic.target.wants/tbm-drm-auth-user.path
 %{_libdir}/libtbm.so.*
 %{_unitdir_user}/tbm-drm-auth-user.path
 %{_unitdir_user}/tbm-drm-auth-user.service
-%if %{with utest}
-%{_bindir}/ut
-%endif
 
 %files devel
 %manifest %{name}.manifest
@@ -104,7 +110,16 @@ rm -f %{_unitdir_user}/basic.target.wants/tbm-drm-auth-user.path
 %{_includedir}/tbm_surface_queue.h
 %{_includedir}/tbm_bufmgr_backend.h
 %{_includedir}/tbm_type.h
+%{_includedir}/tbm_type_int.h
 %{_includedir}/tbm_drm_helper.h
 %{_includedir}/tbm_sync.h
+%{_includedir}/tbm_bo.h
+%{_includedir}/tbm_log.h
 %{_libdir}/libtbm.so
 %{_libdir}/pkgconfig/libtbm.pc
+
+%if "%{UTEST_PACKAGE}" == "1"
+%files utests
+%defattr(-,root,root,-)
+%{_bindir}/tbm-utests
+%endif