Add the module name in the gcov install path
[platform/core/telephony/libtapi.git] / packaging / libtapi.spec
index f0b42f4..4ecfd02 100644 (file)
@@ -84,8 +84,8 @@ find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 %make_install
 
 %if 0%{?gcov:1}
-mkdir -p %{buildroot}%{_datadir}/gcov/obj
-install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
+mkdir -p %{buildroot}%{_datadir}/gcov/obj/%{name}
+install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj/%{name}/
 %endif
 
 rm -rf %{buildroot}%{_includedir}/telephony/tapi/.gitignore