Add API for update-control plugins
[platform/core/system/libsyscommon.git] / packaging / libsyscommon.spec
index e7d9c82..1d112a6 100644 (file)
@@ -2,6 +2,7 @@
 %define libsyscommon_plugin_api_common_version 0.1.0
 %define libsyscommon_plugin_api_resourced_version 0.1.0
 %define libsyscommon_plugin_api_deviced_version 0.1.0
+%define libsyscommon_plugin_api_update_control_version 0.1.0
 
 Name:           libsyscommon
 Summary:        System Libraries
@@ -20,6 +21,7 @@ BuildRequires:  pkgconfig(gio-unix-2.0)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(json-c)
 BuildRequires:  pkgconfig(capi-system-info)
+BuildRequires:  pkgconfig(capi-system-resource)
 
 Requires:         /bin/cp
 Requires(post):   /sbin/ldconfig
@@ -82,6 +84,22 @@ License:     MIT
 %description -n libsyscommon-plugin-api-deviced-devel
 Development header files for system plugin APIs for the deviced.
 
+%package -n libsyscommon-plugin-api-update-control
+Summary:       System plugin API for the update-control
+Version:       %{libsyscommon_plugin_api_update_control_version}
+License:       MIT
+
+%description -n libsyscommon-plugin-api-update-control
+System plugin API for update-control.
+
+%package -n libsyscommon-plugin-api-update-control-devel
+Summary:       Header files for system plugin API for update-control
+Version:       %{libsyscommon_plugin_api_update_control_version}
+License:       MIT
+
+%description -n libsyscommon-plugin-api-update-control-devel
+Development header files for system plugin API for update-control.
+
 
 ######
 
@@ -94,6 +112,7 @@ cp %{SOURCE1001} .
 PLUGIN_API_COMMON_MAJORVER=$(echo %{libsyscommon_plugin_api_common_version} | cut -d'.' -f1)
 PLUGIN_API_RESOURCED_MAJORVER=$(echo %{libsyscommon_plugin_api_resourced_version} | cut -d'.' -f1)
 PLUGIN_API_DEVICED_MAJORVER=$(echo %{libsyscommon_plugin_api_deviced_version} | cut -d'.' -f1)
+PLUGIN_API_UPDATE_CONTROL_MAJORVER=$(echo %{libsyscommon_plugin_api_update_control} | cut -d'.' -f1)
 %cmake . -DFULLVER=%{libsyscommon_version} \
        -DPLUGIN_API_COMMON_VERSION=%{libsyscommon_plugin_api_common_version} \
        -DPLUGIN_API_COMMON_MAJORVER=${PLUGIN_API_COMMON_MAJORVER} \
@@ -101,9 +120,12 @@ PLUGIN_API_DEVICED_MAJORVER=$(echo %{libsyscommon_plugin_api_deviced_version} |
        -DPLUGIN_API_RESOURCED_MAJORVER=${PLUGIN_API_RESOURCED_MAJORVER} \
        -DPLUGIN_API_DEVICED_VERSION=%{libsyscommon_plugin_api_deviced_version} \
        -DPLUGIN_API_DEVICED_MAJORVER=${PLUGIN_API_DEVICED_MAJORVER} \
+       -DPLUGIN_API_UPDATE_CONTROL_VERSION=%{libsyscommon_plugin_api_update_control_version} \
+       -DPLUGIN_API_UPDATE_CONTROL_MAJORVER=${PLUGIN_API_UPDATE_CONTROL_MAJORVER} \
        -DPLUGIN_API_COMMON_ENABLE_DLOG=1 \
        -DPLUGIN_API_RESOURCED_ENABLE_DLOG=1 \
-       -DPLUGIN_API_DEVICEDD_ENABLE_DLOG=1
+       -DPLUGIN_API_DEVICED_ENABLE_DLOG=1 \
+       -DPLUGIN_API_UPDATE_CONTROL_ENABLE_DLOG=1
 make %{?_smp_mflags}
 
 %install
@@ -182,3 +204,17 @@ Common system plugin APIs to load another APIs from backend.
 %{_includedir}/system/syscommon-plugin-deviced*.h
 %{_libdir}/pkgconfig/libsyscommon-plugin-api-deviced.pc
 %{_libdir}/libsyscommon-plugin-api-deviced.so
+
+%files -n libsyscommon-plugin-api-update-control
+%defattr(-,root,root,-)
+%manifest %{name}.manifest
+%license LICENSE.MIT
+%{_libdir}/libsyscommon-plugin-api-update-control.so.*
+
+%files -n libsyscommon-plugin-api-update-control-devel
+%defattr(-,root,root,-)
+%manifest %{name}.manifest
+%license LICENSE.MIT
+%{_includedir}/system/syscommon-plugin-update-control*.h
+%{_libdir}/pkgconfig/libsyscommon-plugin-api-update-control.pc
+%{_libdir}/libsyscommon-plugin-api-update-control.so