Upgrade to 2.62.2
[platform/upstream/libsoup.git] / packaging / libsoup.spec
old mode 100755 (executable)
new mode 100644 (file)
index 5c077c8..74342aa
@@ -2,13 +2,13 @@
 %bcond_with introspection
 
 Name:           libsoup
-Version:        2.46.0
-Release:        0
+Version:        2.62.2
+Release:        1
 License:        LGPL-2.0+
 Summary:        HTTP client/server library for GNOME
 Url:            http://www.gnome.org
 Group:          System/Libraries
-Source:         http://download.gnome.org/sources/libsoup/2.41/%{name}-%{version}.tar.xz
+Source:         http://download.gnome.org/sources/libsoup/2.62/%{name}-%{version}.tar.xz
 Source99:       baselibs.conf
 Source1001:     libsoup.manifest
 Requires:       glib-networking
@@ -24,9 +24,9 @@ BuildRequires:  gnome-common
 BuildRequires:  intltool >= 0.35.0
 BuildRequires:  sqlite-devel
 BuildRequires:  which
+BuildRequires:  python3
 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
 BuildRequires:  pkgconfig(libxml-2.0)
-BuildRequires:  pkgconfig(dlog)
 
 %description
 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
@@ -86,28 +86,10 @@ chmod +x autogen.sh
     --with-gnome \
 %else
     --without-gnome \
-    --enable-sqlite=yes \
     --disable-tls-check \
 %endif
-%if "%{?profile}" == "tv"
-    --enable-tizen-client-certificate=yes \
-    --enable-tizen-disable-mime-sniff \
-    --enable-tizen-text-storage-mode-of-cookie \
-    --enable-tizen-soup-cache-clean-leaked-resources \
-    --enable-tizen-tv-soup-cache-optimise-load-time \
-    --enable-tizen-use-expanded-response-block=yes \
-    --enable-tizen-create-idle-tcp-connection \
-    --enable-tizen-immediate-requesting \
-    --enable-tizen-computing-disk-cache-size \
-    --enable-tizen-add-x-soup-message-headers \
-    --enable-tizen-dynamic-certificate-loading \
-    --enable-tizen-certificate-handling \
-    --enable-tizen-tv-checking-deleted-entry-file \
-    --enable-tizen-tv-force-preload-tlsdb \
-    --enable-tizen-tv-no-cache-about-video-and-audio \
-    --enable-tizen-performance-test-log \
-%endif
-    --disable-static
+    --disable-static \
+    --enable-vala=no
 make %{?_smp_mflags}
 
 %install
@@ -124,7 +106,7 @@ make %{?_smp_mflags}
 %files
 %manifest %{name}.manifest
 %defattr(-, root, root)
-%doc COPYING
+%license COPYING
 %{_libdir}/*.so.*
 
 %if %{with introspection}