Upgrade to 2.62.2
[platform/upstream/libsoup.git] / packaging / libsoup.spec
index 1f7ed17..74342aa 100644 (file)
@@ -1,25 +1,31 @@
 %bcond_with gnome
+%bcond_with introspection
 
 Name:           libsoup
-Version:        2.41.2
-Release:        2.1
-License:        LGPL-2.1+
+Version:        2.62.2
+Release:        1
+License:        LGPL-2.0+
 Summary:        HTTP client/server library for GNOME
 Url:            http://www.gnome.org
-Group:          Development/Libraries/GNOME
-Source:         http://download.gnome.org/sources/libsoup/2.40/%{name}-%{version}.tar.xz
+Group:          System/Libraries
+Source:         http://download.gnome.org/sources/libsoup/2.62/%{name}-%{version}.tar.xz
 Source99:       baselibs.conf
-# Patches auto-generated by git-buildpackage:
+Source1001:     libsoup.manifest
+Requires:       glib-networking
 BuildRequires:  gettext-tools
 BuildRequires:  glib-networking
-%if %{with gnome}
+%if %{with introspection}
 BuildRequires:  gobject-introspection-devel
+%endif
+%if %{with gnome}
 BuildRequires:  pkgconfig(gnome-keyring-1)
+BuildRequires:  gnome-common
 %endif
 BuildRequires:  intltool >= 0.35.0
-BuildRequires:  sqlite3-devel
+BuildRequires:  sqlite-devel
+BuildRequires:  which
+BuildRequires:  python3
 BuildRequires:  pkgconfig(glib-2.0) >= 2.35.0
-BuildRequires:  gnome-common
 BuildRequires:  pkgconfig(libxml-2.0)
 
 %description
@@ -47,9 +53,11 @@ This package provides the GObject Introspection bindings for libsoup.
 
 %package devel
 Summary:        HTTP client/server library for GNOME - Development Files
-Group:          Development/Libraries/GNOME
+Group:          Social & Content/GNOME
 Requires:       %{name} = %{version}
+%if %{with gnome}
 Requires:       typelib-Soup = %{version}
+%endif
 
 %description devel
 Libsoup is an HTTP client/server library for GNOME. It uses GObjects
@@ -66,18 +74,22 @@ Features:
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
+chmod +x autogen.sh
 %autogen\
+%if %{with introspection}
+    --enable-introspection \
+%endif
 %if %{with gnome}
-     --with-gnome \
-     --enable-introspection \
+    --with-gnome \
 %else
-     --without-gnome \
-     --enable-sqllite=yes \
+    --without-gnome \
     --disable-tls-check \
 %endif
-    --disable-static 
+    --disable-static \
+    --enable-vala=no
 make %{?_smp_mflags}
 
 %install
@@ -92,24 +104,31 @@ make %{?_smp_mflags}
 %lang_package
 
 %files
+%manifest %{name}.manifest
 %defattr(-, root, root)
-%license  COPYING
+%license COPYING
 %{_libdir}/*.so.*
 
+%if %{with introspection}
 %files -n typelib-Soup
+%manifest %{name}.manifest
 %defattr(-,root,root)
-%if %{with gnome}
 %{_libdir}/girepository-1.0/Soup-2.4.typelib
+%if %{with gnome}
 %{_libdir}/girepository-1.0/SoupGNOME-2.4.typelib
 %endif
+%endif
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_includedir}/libsoup-2.4
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/*.pc
-%if %{with gnome}
+%if %{with introspection}
 %{_datadir}/gir-1.0/Soup-2.4.gir
+%if %{with gnome}
 %{_datadir}/gir-1.0/SoupGNOME-2.4.gir
 %{_includedir}/libsoup-gnome-2.4
 %endif
+%endif