Update package version to 0.6.57
[platform/core/uifw/libscl-ui.git] / packaging / libscl-ui.spec
index 4e016da..621fe95 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:       libscl-ui
 Summary:    A library for developing XML-based software keyboards
-Version:    0.6.47
+Version:    0.6.57
 Release:    1
 Group:      Graphics & UI Framework/Input
 License:    Apache-2.0
@@ -11,6 +11,7 @@ Source0:    %{name}-%{version}.tar.gz
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(elementary)
 %if %{with wayland}
+BuildRequires:  pkgconfig(ecore-wayland)
 %else
 BuildRequires:  pkgconfig(ecore-x)
 BuildRequires:  pkgconfig(x11)
@@ -40,13 +41,17 @@ A devel package of libscl-ui library that helps developing S/W Keyboard
 
 
 %build
+export CFLAGS+=" -fvisibility=hidden -DTIZEN_DEBUG_ENABLE -Werror"
+export CXXFLAGS+=" -fvisibility=hidden -fvisibility-inlines-hidden -DTIZEN_DEBUG_ENABLE -Werror"
+export FFLAGS+=" -DTIZEN_DEBUG_ENABLE"
+
 rm -rf CMakeFiles
 rm -rf CMakeCache.txt
 
 %if %{with wayland}
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir} -Dwith_wayland=TRUE
+%cmake . -Dwith_wayland=TRUE
 %else
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIB_INSTALL_DIR:PATH=%{_libdir}
+%cmake .
 %endif
 make %{?_smp_mflags}