During package installation there is no test for /opt/dbspace existence.
[platform/core/security/libprivilege-control.git] / packaging / libprivilege-control.spec
index c300e47..92d9aaa 100644 (file)
@@ -57,6 +57,13 @@ ln -sf /usr/lib/systemd/system/smack-rules.service %{buildroot}/usr/lib/systemd/
 
 %post
 /sbin/ldconfig
+
+if [ ! -e "/opt/dbspace" ]
+then
+    mkdir -p /opt/dbspace
+    chmod 775 /opt/dbspace
+fi
+
 /usr/share/privilege-control/db/updater.sh
 
 %postun -p /sbin/ldconfig