Add color pick enabled feature for product TV
[platform/upstream/libpng.git] / packaging / libpng.spec
index 118e429..624570d 100644 (file)
@@ -1,5 +1,5 @@
 Name:           libpng
-Version:        1.6.13
+Version:        1.6.21
 Release:        1
 License:        Zlib
 Summary:        A library of functions for manipulating PNG image format files
@@ -22,7 +22,7 @@ files.
 %package devel
 Summary:        Development tools for programs to manipulate PNG image format files
 Group:          Development/Libraries
-Requires:       %{name} = %{version}
+Requires:       %{name} = %{version}-%{release}
 Requires:       zlib-devel
 
 %description devel
@@ -34,6 +34,13 @@ for developing programs using the PNG (Portable Network Graphics) library.
 cp %{SOURCE1001} .
 
 %build
+%ifarch %{arm}
+CFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
+%endif
+
+%if 0%{?TIZEN_PRODUCT_TV}
+CFLAGS+=" -D_PNG_COLOR_PICK_ENABLED_ -D_PNG_SEQUENTIAL_READ_SUPPORTED_"
+%endif
 
 %configure \
     --disable-static \
@@ -42,7 +49,7 @@ cp %{SOURCE1001} .
 %endif
 
 
-make %{?_smp_mflags}
+%__make %{?_smp_mflags}
 
 %install
 %make_install