remove aarch64 for neon check
[platform/upstream/libpng.git] / packaging / libpng.spec
index 35120d8..438294a 100644 (file)
@@ -1,11 +1,12 @@
 Name:           libpng
-Version:        1.2.50
-Release:        1
-License:        zlib
+Version:        1.6.37
+Release:        2
+License:        Libpng
 Summary:        A library of functions for manipulating PNG image format files
-Url:            http://www.libpng.org/pub/png/
+Url:            http://www.libpng.org/pub/png/libpng.html
 Group:          System/Libraries
 Source:         %{name}-%{version}.tar.bz2
+Source1001:     libpng.manifest
 BuildRequires:  zlib-devel
 
 %description
@@ -21,8 +22,7 @@ files.
 %package devel
 Summary:        Development tools for programs to manipulate PNG image format files
 Group:          Development/Libraries
-Requires:       %{name} = %{version}
-Requires:       libpng = %{version}
+Requires:       %{name} = %{version}-%{release}
 Requires:       zlib-devel
 
 %description devel
@@ -31,11 +31,22 @@ for developing programs using the PNG (Portable Network Graphics) library.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
+%ifarch %{arm}
+CFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
+%endif
 
-%configure --disable-static
-make %{?_smp_mflags}
+%configure \
+    --disable-static \
+%ifarch %{arm}
+    --enable-arm-neon=check \
+    %{?ubsan: --enable-arm-neon=no}
+%endif
+
+
+%__make %{?_smp_mflags}
 
 %install
 %make_install
@@ -45,9 +56,12 @@ rm -rf %{buildroot}/usr/share/man
 %postun -p /sbin/ldconfig
 
 %files
+%manifest %{name}.manifest
+%license LICENSE
 %{_libdir}/libpng*.so.*
 
 %files devel
+%manifest %{name}.manifest
 %{_bindir}/*
 %{_includedir}/*
 %{_libdir}/libpng*.so