remove aarch64 for neon check
[platform/upstream/libpng.git] / packaging / libpng.spec
index 118e429..438294a 100644 (file)
@@ -1,9 +1,9 @@
 Name:           libpng
-Version:        1.6.13
-Release:        1
-License:        Zlib
+Version:        1.6.37
+Release:        2
+License:        Libpng
 Summary:        A library of functions for manipulating PNG image format files
-Url:            http://www.libpng.org/pub/png/
+Url:            http://www.libpng.org/pub/png/libpng.html
 Group:          System/Libraries
 Source:         %{name}-%{version}.tar.bz2
 Source1001:     libpng.manifest
@@ -22,7 +22,7 @@ files.
 %package devel
 Summary:        Development tools for programs to manipulate PNG image format files
 Group:          Development/Libraries
-Requires:       %{name} = %{version}
+Requires:       %{name} = %{version}-%{release}
 Requires:       zlib-devel
 
 %description devel
@@ -34,15 +34,19 @@ for developing programs using the PNG (Portable Network Graphics) library.
 cp %{SOURCE1001} .
 
 %build
+%ifarch %{arm}
+CFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
+%endif
 
 %configure \
     --disable-static \
-%ifarch %arm armv7l armv7el aarch64
-    --enable-arm-neon=check
+%ifarch %{arm}
+    --enable-arm-neon=check \
+    %{?ubsan: --enable-arm-neon=no}
 %endif
 
 
-make %{?_smp_mflags}
+%__make %{?_smp_mflags}
 
 %install
 %make_install