Use cmake instead of configure
[platform/upstream/libpng.git] / packaging / libpng.spec
index 0708d45..10b6ca9 100644 (file)
@@ -1,12 +1,14 @@
 Name:           libpng
-Version:        1.6.13
-Release:        1
-License:        Zlib
+Version:        1.6.37
+Release:        3
+License:        Libpng
 Summary:        A library of functions for manipulating PNG image format files
-Url:            http://www.libpng.org/pub/png/
+Url:            http://www.libpng.org/pub/png/libpng.html
 Group:          System/Libraries
 Source:         %{name}-%{version}.tar.bz2
 Source1001:     libpng.manifest
+
+BuildRequires:  cmake
 BuildRequires:  zlib-devel
 
 %description
@@ -22,7 +24,7 @@ files.
 %package devel
 Summary:        Development tools for programs to manipulate PNG image format files
 Group:          Development/Libraries
-Requires:       %{name} = %{version}
+Requires:       %{name} = %{version}-%{release}
 Requires:       zlib-devel
 
 %description devel
@@ -34,9 +36,21 @@ for developing programs using the PNG (Portable Network Graphics) library.
 cp %{SOURCE1001} .
 
 %build
+%ifarch %{arm}
+CFLAGS+=" -D_ARCH_ARM_ -mfpu=neon"
+%endif
+
+%cmake . -DPNG_STATIC=OFF \
+         -DSKIP_INSTALL_PROGRAMS=ON \
+         -DSKIP_INSTALL_EXPORT=ON \
+%ifarch %{arm}
+         -DPNG_ARM_NEON=check \
+%else
+         -DPNG_ARM_NEON=off \
+%endif
+         %{?ubsan: -DPNG_ARM_NEON=off}
 
-%configure --disable-static
-make %{?_smp_mflags}
+make %{?jobs:-j%jobs}
 
 %install
 %make_install