use _libdir on Tizen
[platform/upstream/libphonenumber.git] / packaging / libphonenumber.spec
index 2c1a4f1..ccde64a 100644 (file)
@@ -1,10 +1,10 @@
 Name:           libphonenumber
 Version:        5.3.2
 Release:        1
-License:        Apache License 2.0
-Summary:        A library for parsing, formatting, storing and validating international phone numbers.
+License:        Apache-2.0
+Summary:        A library for manipulating international phone numbers
 Url:            http://code.google.com/p/libphonenumber/
-Group:          Development/Libraries/C and C++
+Group:          Social & Content/Libraries
 Source:         libphonenumber-%{version}.tgz
 BuildRequires:  gcc-c++
 BuildRequires:  cmake
@@ -21,9 +21,8 @@ Java version is optimized for running on smartphones, and is used by
 the Android framework since 4.0 (Ice Cream Sandwich).
 
 %package devel
-License:        Apache License 2.0
-Summary:        A library for parsing, formatting, storing and validating international phone numbers.
-Group:          Development/Libraries/C and C++
+Summary:        Devel package for library
+Group:          Social & Content/Libraries
 Requires:       libphonenumber = %{version}
 Requires:       protobuf-devel
 
@@ -37,9 +36,13 @@ the Android framework since 4.0 (Ice Cream Sandwich).
 %setup -q -n libphonenumber
 
 %build
-cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} cpp
+cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} -DCMAKE_INSTALL_LIBDIR=%{_libdir} cpp
 
-%{__make} %{?jobs:-j%jobs}
+# Parallel builds are broken and/or not supported by upstream, don't
+# use them. The generated Makefile lacks the geocoding_data.cc ->
+# generate_geocoding_data dependency and thus code generator may still
+# be producing the file when the C++ compiler is already parsing it.
+%{__make}
 
 %install
 %{__make} DESTDIR=%{buildroot} install
@@ -52,7 +55,8 @@ rm %{buildroot}/%{_libdir}/*.a
 
 %files -n libphonenumber
 %defattr(-, root, root, -)
-%doc AUTHORS LICENSE
+%doc AUTHORS
+%license LICENSE
 %{_libdir}/libphonenumber.so.5
 %{_libdir}/libphonenumber.so.5.3
 %{_libdir}/libgeocoding.so.5