use _libdir on Tizen
[platform/upstream/libphonenumber.git] / packaging / libphonenumber.spec
index 2501cee..ccde64a 100644 (file)
@@ -36,9 +36,13 @@ the Android framework since 4.0 (Ice Cream Sandwich).
 %setup -q -n libphonenumber
 
 %build
-cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} cpp
+cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} -DCMAKE_INSTALL_LIBDIR=%{_libdir} cpp
 
-%{__make} %{?jobs:-j%jobs}
+# Parallel builds are broken and/or not supported by upstream, don't
+# use them. The generated Makefile lacks the geocoding_data.cc ->
+# generate_geocoding_data dependency and thus code generator may still
+# be producing the file when the C++ compiler is already parsing it.
+%{__make}
 
 %install
 %{__make} DESTDIR=%{buildroot} install