exclude arch TV
[platform/upstream/libphonenumber.git] / packaging / libphonenumber.spec
index 869bc11..5bd7985 100644 (file)
@@ -1,11 +1,16 @@
 Name:           libphonenumber
-Version:        5.3.2
+Version:        7.0.6
 Release:        1
 License:        Apache-2.0
 Summary:        A library for manipulating international phone numbers
 Url:            http://code.google.com/p/libphonenumber/
 Group:          Social & Content/Libraries
 Source:         libphonenumber-%{version}.tgz
+
+%if "%{?tizen_profile_name}" == "tv"
+ExcludeArch: %{arm} %ix86 x86_64
+%endif
+
 BuildRequires:  gcc-c++
 BuildRequires:  cmake
 BuildRequires:  gtest-devel
@@ -36,7 +41,7 @@ the Android framework since 4.0 (Ice Cream Sandwich).
 %setup -q -n libphonenumber
 
 %build
-cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} cpp
+cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} -DCMAKE_INSTALL_LIBDIR=%{_libdir} cpp
 
 # Parallel builds are broken and/or not supported by upstream, don't
 # use them. The generated Makefile lacks the geocoding_data.cc ->
@@ -47,6 +52,8 @@ cmake -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=%{_prefix} cpp
 %install
 %{__make} DESTDIR=%{buildroot} install
 rm %{buildroot}/%{_libdir}/*.a
+# Exported header has dependency on lock_posix.h but lock_posix.h is not installed.
+cp cpp/src/phonenumbers/base/synchronization/lock_posix.h %{buildroot}/%{_includedir}/phonenumbers/base/synchronization/
 
 %post   -n libphonenumber -p /sbin/ldconfig
 
@@ -57,14 +64,11 @@ rm %{buildroot}/%{_libdir}/*.a
 %defattr(-, root, root, -)
 %doc AUTHORS
 %license LICENSE
-%{_libdir}/libphonenumber.so.5
-%{_libdir}/libphonenumber.so.5.3
-%{_libdir}/libgeocoding.so.5
-%{_libdir}/libgeocoding.so.5.3
+%{_libdir}/libphonenumber.so.*
+%{_libdir}/libgeocoding.so.*
 
 %files devel
 %defattr(-, root, root, -)
 %{_includedir}/phonenumbers
-%{_includedir}/base
 %{_libdir}/libphonenumber.so
 %{_libdir}/libgeocoding.so