Add SC(Stack Canary) flags
[platform/upstream/libpciaccess.git] / packaging / libpciaccess.spec
index 5a81b29..6506160 100644 (file)
@@ -42,7 +42,7 @@ cp %{SOURCE1001} .
 NOCONFIGURE=1
 %autogen
 export CFLAGS="$CFLAGS -w"
-export CFLAGS="-O2 -g2 -pipe -w -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector -fmessage-length=0 -Wl,--as-needed -Wl,-z,relro"
+export CFLAGS="-O2 -g2 -pipe -w -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong -fmessage-length=0 -Wl,--as-needed -Wl,-z,relro"
 %configure --disable-static \
            --with-pciids-path=%{_datadir}/misc --with-zlib
 make %{?_smp_mflags}