Correct license information
[platform/adaptation/broadcom/libomxil-vc4.git] / packaging / libomxil-vc4.spec
index c75b975..6fbd034 100755 (executable)
@@ -1,15 +1,16 @@
 Name:          libomxil-vc4
 Version:       0.0.1
-Release:       0.1
+Release:       3
 Summary:       Libraries for interfacing to Raspberry Pi GPU
 Group:         System/Libraries
 URL:           https://github.com/raspberrypi/userland
 Source:         %{name}-%{version}.tar.gz
-License:       BSD
+License:       BSD-3-Clause
 BuildRequires: glibc-devel
 BuildRequires: cmake
 BuildRequires: gcc-c++
 BuildRequires: pkgconfig(libtbm)
+ExclusiveArch: %{arm}
 
 %description
 Libraries for interfacing to Raspberry Pi GPU.
@@ -41,7 +42,15 @@ cmake -DCMAKE_BUILD_TYPE=Release ../../../
 make
 popd
 
+%post
+/sbin/ldconfig
+
+%postun
+/sbin/ldconfig
+
 %install
+mkdir -p %{buildroot}/etc/ld.so.conf.d/
+cp %{_builddir}/%{name}-%{version}/packaging/libomxil-vc4.conf %{buildroot}/etc/ld.so.conf.d
 mkdir -p %{buildroot}/opt/vc/lib/plugins
 mkdir %{buildroot}/opt/vc/lib/pkgconfig
 mkdir %{buildroot}/opt/vc/bin
@@ -85,14 +94,15 @@ popd
 
 %files -n libomxil-vc4-utils
 /opt/vc/bin/*
-%doc LICENCE COPYING
+%doc LICENSE
 
 %files -n libomxil-vc4
 %manifest packaging/%{name}.manifest
 %defattr(-,root,root)
-%license LICENCE COPYING
+%license LICENSE
 /opt/vc/lib/lib*.so
 /opt/vc/lib/plugins/*.so
+/etc/ld.so.conf.d/libomxil-vc4.conf
 
 %files -n libomxil-vc4-devel
 /opt/vc/lib/lib*.a