Clean up spec file
[platform/adaptation/broadcom/libomxil-vc4.git] / packaging / libomxil-vc4.spec
index 35703da..06d2384 100755 (executable)
@@ -1,12 +1,11 @@
 Name:          libomxil-vc4
 Version:       0.0.1
-Release:       2
+Release:       4
 Summary:       Libraries for interfacing to Raspberry Pi GPU
 Group:         System/Libraries
 URL:           https://github.com/raspberrypi/userland
 Source:         %{name}-%{version}.tar.gz
-License:       BSD
-BuildRequires: glibc-devel
+License:       BSD-3-Clause
 BuildRequires: cmake
 BuildRequires: gcc-c++
 BuildRequires: pkgconfig(libtbm)
@@ -15,19 +14,20 @@ ExclusiveArch: %{arm}
 %description
 Libraries for interfacing to Raspberry Pi GPU.
 
-%package -n    libomxil-vc4-utils
+%package       utils
 Group:         System/Tools
 Summary:       System tools for the Raspberry Pi
 
-%description -n libomxil-vc4-utils
+%description   utils
 This package contains some system tools for the Raspberry Pi.
 Source: https://github.com/libomxil-vc4/userland.git
 
-%package -n libomxil-vc4-devel
+%package       devel
 Group:         Development/Libraries
 Summary:       Development files for the Raspberry Pi GPU
+Requires:      %{name} = %{version}
 
-%description -n libomxil-vc4-devel
+%description   devel
 This package contains libraries and header files for developing applications that use Raspberry Pi GPU.
 
 %prep
@@ -92,19 +92,19 @@ popd
 %clean
 [ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
 
-%files -n libomxil-vc4-utils
-/opt/vc/bin/*
-%doc LICENCE
-
-%files -n libomxil-vc4
+%files
 %manifest packaging/%{name}.manifest
 %defattr(-,root,root)
-%license LICENCE
+%license LICENSE
 /opt/vc/lib/lib*.so
 /opt/vc/lib/plugins/*.so
 /etc/ld.so.conf.d/libomxil-vc4.conf
 
-%files -n libomxil-vc4-devel
+%files utils
+/opt/vc/bin/*
+%doc LICENSE
+
+%files devel
 /opt/vc/lib/lib*.a
 /opt/vc/include/EGL
 /opt/vc/include/GLES
@@ -117,3 +117,4 @@ popd
 /opt/vc/include/vcinclude
 /opt/vc/include/*.h
 /opt/vc/lib/pkgconfig/*.pc
+