Add tool package to separate testsuite binary
[platform/core/multimedia/libmm-streamrecorder.git] / packaging / libmm-streamrecorder.spec
index be7d419..7f396b8 100644 (file)
@@ -1,6 +1,6 @@
 Name:       libmm-streamrecorder
 Summary:    Media Stream Recorder library
-Version:    0.0.12
+Version:    0.0.38
 Release:    0
 Group:      Multimedia/Other
 License:    Apache-2.0
@@ -8,11 +8,15 @@ Source0:    %{name}-%{version}.tar.gz
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  pkgconfig(mm-common)
-BuildRequires:  pkgconfig(mm-log)
+BuildRequires:  pkgconfig(capi-media-tool)
+BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(gstreamer-base-1.0)
 BuildRequires:  pkgconfig(gstreamer-video-1.0)
 BuildRequires:  pkgconfig(gstreamer-app-1.0)
 BuildRequires:  pkgconfig(iniparser)
+%if 0%{?gtests:1}
+BuildRequires:  pkgconfig(gmock)
+%endif
 
 %description
 This library is for making video/audio files with gstreamer
@@ -27,23 +31,32 @@ Requires:   %{name} = %{version}-%{release}
 %description devel
 Media Stream Recorder development library
 
+%package tool
+Summary: stream recorder utility package
+Group:      Development/Tools
+Requires:   %{name} = %{version}-%{release}
+
+%description tool
+A tool for Media Stream Recorder development library
 
 %prep
 %setup -q
 
-
 %build
 #export CFLAGS+=" -DGST_EXT_TIME_ANALYSIS"
 export CFLAGS+=" -Wall -Wextra -Wno-array-bounds -Wno-empty-body -Wno-ignored-qualifiers -Wno-unused-parameter -Wshadow -Wwrite-strings -Wswitch-default -Wno-unused-but-set-parameter -Wno-unused-but-set-variable"
-export CFLAGS+=" -DSYSCONFDIR=\\\"%{_sysconfdir}\\\""
+export CFLAGS+=" -DSYSCONFDIR=\\\"%{_hal_sysconfdir}\\\""
 ./autogen.sh
-%configure --disable-static
+%configure \
+%if 0%{?gtests:1}
+--enable-tests \
+%endif
+--disable-static
+
 make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
-mkdir -p %{buildroot}/usr/share/license
-cp LICENSE.APLv2 %{buildroot}/usr/share/license/%{name}
 %make_install
 
 %clean
@@ -55,15 +68,22 @@ rm -rf %{buildroot}
 %postun -p /sbin/ldconfig
 
 %files
-%manifest libmm-streamrecorder.manifest
+%manifest %{name}.manifest
+%license LICENSE.APLv2
 %defattr(-,root,root,-)
-%{_bindir}/*
 %{_libdir}/*.so.*
-%{_datadir}/license/%{name}
-
+%if 0%{?gtests:1}
+%{_bindir}/gtest-%{name}
+%endif
 
 %files devel
 %defattr(-,root,root,-)
 %{_includedir}/mmf/mm_streamrecorder.h
 %{_libdir}/pkgconfig/mm-streamrecorder.pc
 %{_libdir}/*.so
+
+%files tool
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%{_bindir}/*
+%license LICENSE.APLv2