[0.6.238] Fix memory leak due to without unref source element
[platform/core/multimedia/libmm-player.git] / packaging / libmm-player.spec
index 7db1ad3..2ef3859 100644 (file)
@@ -1,6 +1,6 @@
 Name:       libmm-player
 Summary:    Multimedia Framework Player Library
-Version:    0.6.195
+Version:    0.6.238
 Release:    0
 Group:      Multimedia/Libraries
 License:    Apache-2.0
@@ -53,6 +53,13 @@ export CFLAGS+=" -DHAVE_X11"
 %endif
 
 LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--hash-style=both -Wl,--as-needed"; export LDFLAGS
+
+%if 0%{?gcov:1}
+export CFLAGS+=" -fprofile-arcs -ftest-coverage"
+export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
+export LDFLAGS+=" -lgcov"
+%endif
+
 ./autogen.sh
 # always enable sdk build. This option should go away
 #CFLAGS=$CFLAGS LDFLAGS=$LDFLAGS ./configure --enable-sdk --prefix=%{_prefix} --disable-static
@@ -60,8 +67,7 @@ LDFLAGS+="-Wl,--rpath=%{_prefix}/lib -Wl,--hash-style=both -Wl,--as-needed"; exp
 %if "%{gtests}" == "1"
 --enable-tests \
 %endif
---disable-static \
---enable-wayland
+--disable-static
 
 #%__make -j1
 make %{?jobs:-j%jobs}