Reset focus register flag not to run sound focus related code when sound signal callb...
[platform/core/multimedia/libmm-camcorder.git] / packaging / libmm-camcorder.spec
index 1bcb778..b49e5d6 100644 (file)
@@ -1,8 +1,6 @@
-%bcond_with wayland
-
 Name:       libmm-camcorder
 Summary:    Camera and recorder library
-Version:    0.10.50
+Version:    0.10.87
 Release:    0
 Group:      Multimedia/Libraries
 License:    Apache-2.0
@@ -20,15 +18,18 @@ BuildRequires:  pkgconfig(mmutil-jpeg)
 BuildRequires:  pkgconfig(gstreamer-base-1.0)
 BuildRequires:  pkgconfig(gstreamer-video-1.0)
 BuildRequires:  pkgconfig(gstreamer-app-1.0)
-%if %{with wayland}
 BuildRequires:  pkgconfig(gstreamer-wayland-1.0)
 BuildRequires:  pkgconfig(wayland-client)
-%endif
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(libtbm)
 BuildRequires:  pkgconfig(storage)
+%if "%{TIZEN_PRODUCT_TV}" != "1"
 BuildRequires:  pkgconfig(murphy-resource)
 BuildRequires:  pkgconfig(murphy-glib)
+%else
+BuildRequires:  pkgconfig(tv-resource-manager)
+BuildRequires:  pkgconfig(aul)
+%endif
 BuildRequires:  pkgconfig(ttrace)
 BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(dpm)
@@ -52,14 +53,14 @@ Camera and recorder function supported library for development.
 
 
 %build
-%if %{with wayland}
-export CFLAGS+=" -DHAVE_WAYLAND -DGST_USE_UNSTABLE_API"
-%endif
-export CFLAGS+=" -D_LARGEFILE64_SOURCE -DSYSCONFDIR=\\\"%{_sysconfdir}\\\" -DTZ_SYS_ETC=\\\"%{TZ_SYS_ETC}\\\""
+export CFLAGS+=" -D_LARGEFILE64_SOURCE -DGST_USE_UNSTABLE_API -DSYSCONFDIR=\\\"%{_sysconfdir}\\\" -DTZ_SYS_ETC=\\\"%{TZ_SYS_ETC}\\\""
 ./autogen.sh
 %configure \
-%if %{with wayland}
-       --enable-wayland \
+%if "%{TIZEN_PRODUCT_TV}" != "1"
+       --enable-murphy \
+%else
+       --enable-rm \
+       --enable-product-tv \
 %endif
        --disable-static
 make %{?jobs:-j%jobs}
@@ -78,7 +79,6 @@ cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
 %files
 %manifest libmm-camcorder.manifest
 %defattr(-,root,root,-)
-%{_bindir}/*
 %{_libdir}/*.so.*
 %{_datadir}/sounds/mm-camcorder/*
 %{_datadir}/license/%{name}