Update coding convention & file-service added.
[platform/framework/web/livebox-viewer.git] / packaging / liblivebox-viewer.spec
index dc9ba15..17f3f7a 100644 (file)
@@ -1,8 +1,8 @@
 Name: liblivebox-viewer
-Summary: Library for the development of a livebox viewer
-Version: 0.8.11
+Summary: Library for developing the application.
+Version: 0.14.1
 Release: 1
-Group: main/app
+Group: HomeTF/Livebox
 License: Flora License
 Source0: %{name}-%{version}.tar.gz
 BuildRequires: cmake, gettext-tools, coreutils
@@ -16,12 +16,13 @@ BuildRequires: pkgconfig(xext)
 BuildRequires: pkgconfig(sqlite3)
 BuildRequires: pkgconfig(db-util)
 BuildRequires: pkgconfig(livebox-service)
+BuildRequires: pkgconfig(vconf)
 
 %description
-Livebox viewer development library
+API for creating a new instance of the livebox and managing its life-cycle.
 
 %package devel
-Summary: Files for livebox viewer development.
+Summary: Header and package configuration files for the livebox viewer development.
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
 
@@ -32,7 +33,12 @@ Livebox viewer development library (dev)
 %setup -q
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
+export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
+export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
+%endif
+%cmake .
 make %{?jobs:-j%jobs}
 
 %install