Sync with the latest one
[platform/framework/web/heap-monitor.git] / packaging / libheap-monitor.spec
index 14daf2c..5fb43f4 100644 (file)
@@ -1,10 +1,11 @@
 Name: libheap-monitor
 Summary: Library for monitoring the heap usage
-Version: 0.0.13
+Version: 0.0.17
 Release: 1
 Group: HomeTF/Livebox
-License: Flora License
+License: Flora
 Source0: %{name}-%{version}.tar.gz
+Source1001: %{name}.manifest
 BuildRequires: cmake, gettext-tools, coreutils
 BuildRequires: pkgconfig(dlog)
 
@@ -12,7 +13,7 @@ BuildRequires: pkgconfig(dlog)
 Monitoring the heap usage to manage them safely.
 
 %package devel
-Summary: Files for implementaion of the heap monitor.
+Summary: Files for implementaion of the heap monitor
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
 
@@ -21,9 +22,22 @@ Monitoring the heap usage to manage them safely.(dev)
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%if 0%{?sec_build_binary_debug_enable}
+export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
+export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
+export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
+%endif
+
+%if 0%{?tizen_build_binary_release_type_eng}
+export CFLAGS="${CFLAGS} -DTIZEN_ENGINEER_MODE"
+export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
+export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
+%endif
+
+%cmake .
 CFLAGS+="${CFLAGS} -fvisibility=hidden -Wall -Werror -Winline -fno-builtin-malloc" make %{?jobs:-j%jobs}
 
 %install
@@ -34,12 +48,13 @@ mkdir -p %{buildroot}/%{_datarootdir}/license
 %post
 
 %files
-%manifest libheap-monitor.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/*.so*
 %{_datarootdir}/license/*
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_includedir}/heap-monitor/heap-monitor.h
 %{_libdir}/pkgconfig/*.pc