reflect previous commit for setting gcc_dir_version to other spec files
[platform/upstream/gcc48.git] / packaging / libgcj48.spec
index 9034f3c..d62930a 100644 (file)
@@ -175,9 +175,7 @@ BuildRequires: gdb
 URL:          http://gcc.gnu.org/
 Version: 4.8.1
 Release:      1
-%define gcc_version %(echo %version | sed 's/_.*//')
-%define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
-%define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
+%define gcc_dir_version 4.8
 %define binsuffix -4.8
 
 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
@@ -205,7 +203,7 @@ Suggests: gcc48-info gcc48-locale
 %endif
 
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
-Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
+Source:                gcc-%{version}.tar.bz2
 Source1:       change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
@@ -230,7 +228,6 @@ Source code for this package is in gcc.
 %package -n gcc48-java
 Summary:      The GNU Java Compiler
 License:        GPL-3.0+
-Group:        Development/Languages/Java
 Requires: gcc48 = %{version}
 Requires: libgcj48-devel = %{version}-%{release}
 
@@ -241,7 +238,6 @@ The Java compiler from the GCC-tools-suite.
 %package -n libgcj_bc%{libgcj_bc_sover}%{libgcj_bc_suffix}
 Summary:      Fake library for BC-ABI compatibility.
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 # libgcj_bc is special in that it just contains a symlink to
 # a proper libgcj version.  So require that library and add
 # provides for the shlib version as created at link time
@@ -262,7 +258,6 @@ libgcj.so changes.
 %package -n libgcj48-jar
 Summary:      Java runtime library (jar files).
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 
 %description -n libgcj48-jar
 These are the jar files that go along with the gcj front end to gcc.
@@ -271,7 +266,6 @@ These are the jar files that go along with the gcj front end to gcc.
 %package -n libgcj48-devel
 Summary:      Include Files and Libraries mandatory for Development.
 License:        GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 Requires: libstdc++48-devel = %{version}
 Requires: libgcj%{libgcj_sover} >= %{version}-%{release}
 Requires: libgcj_bc%{libgcj_bc_sover} >= %{version}-%{release}
@@ -292,7 +286,6 @@ to develop applications that require these.
 %package -n gcc48-gij
 Summary:      Java Bytecode Interpreter for gcc
 License:      GPL-2.0-with-classpath-exception
-Group:        Development/Libraries/Java
 Requires: libgcj%{libgcj_sover} >= %{version}-%{release}
 
 %description -n gcc48-gij
@@ -301,7 +294,6 @@ This package contains the java bytecode interpreter gij and related tools.
 %package -n libffi%{libffi_sover}%{libffi_suffix}
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -314,7 +306,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -327,7 +318,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -341,7 +331,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover} >= %{version}-%{release}
 
 %description -n libffi48-devel
@@ -349,7 +338,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-32bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-32bit >= %{version}-%{release}
 
 %description -n libffi48-devel-32bit
@@ -357,7 +345,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-64bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-64bit >= %{version}-%{release}
 
 %description -n libffi48-devel-64bit
@@ -366,7 +353,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc48-testresults
 Summary:      Testsuite results
 License:       SUSE-Public-Domain
-Group:        Development/Languages/C and C++
 
 %description -n gcc48-testresults
 Results from running the gcc and target library testsuites.
@@ -483,7 +469,7 @@ Results from running the gcc and target library testsuites.
 
 
 %prep
-%setup -q -n gcc-%{gcc_version}%{snapshot_date}
+%setup -q -n gcc-%{version}
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -695,10 +681,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %endif
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
-       --with-tune=cortex-a9 \
-       --with-float=hard \
-       --with-abi=aapcs-linux \
-       --with-fpu=vfpv3-d16 \
+       --with-tune=cortex-a8 \
+       --with-float=softfp \
+       --with-fpu=vfpv3 \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"