Add armv7l support and fix build error of cross gcc.
[platform/upstream/gcc48.git] / packaging / libgcj48.spec
index 9034f3c..3f54955 100644 (file)
@@ -205,7 +205,7 @@ Suggests: gcc48-info gcc48-locale
 %endif
 
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
-Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
+Source:                gcc-%{version}.tar.bz2
 Source1:       change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
@@ -483,7 +483,7 @@ Results from running the gcc and target library testsuites.
 
 
 %prep
-%setup -q -n gcc-%{gcc_version}%{snapshot_date}
+%setup -q -n gcc-%{version}
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -696,8 +696,7 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
        --with-tune=cortex-a9 \
-       --with-float=hard \
-       --with-abi=aapcs-linux \
+    --with-float=soft \
        --with-fpu=vfpv3-d16 \
        --disable-sjlj-exceptions \
 %endif