Merge branch 'tizen' of ssh://review.tizen.org/platform/upstream/gcc48 into tizen
[platform/upstream/gcc48.git] / packaging / libffi48.spec
index 9dceb80..e5894a6 100644 (file)
 %endif
 
 # Shared library SONAME versions
-%ifarch hppa
-%define libgcc_s 4
-%else
 %define libgcc_s 1
-%endif
-%define libgcj_sover 14
-%define libgcj_bc_sover 1
-%define libffi_sover 4
-%define libmudflap_sover 0
-%define libgomp_sover 1
-%define libstdcxx_sover 6
-%define libobjc_sover 4
-%define libgfortran_sover 3
-%define libquadmath_sover 0
-%define libasan_sover 0
-%define libtsan_sover 0
-%define libatomic_sover 1
-%define libitm_sover 1
+%define libgcj_sover %{nil}
+%define libgcj_bc_sover %{nil}
+%define libffi_sover %{nil}
+%define libmudflap_sover %{nil}
+%define libgomp_sover %{nil}
+%define libstdcxx_sover %{nil}
+%define libobjc_sover %{nil}
+%define libgfortran_sover %{nil}
+%define libquadmath_sover %{nil}
+%define libasan_sover %{nil}
+%define libtsan_sover %{nil}
+%define libatomic_sover %{nil}
+%define libitm_sover %{nil}
 
 # Shared library package suffix
 # This is used for the "non-standard" set of libraries, the standard
@@ -209,14 +205,14 @@ Suggests: gcc48-info gcc48-locale
 %endif
 
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
-Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
+Source:                gcc-%{version}.tar.bz2
 Source1:       change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
 Source6:       baselibs.conf
 
 
-Group:         Development/Languages/C and C++
+Group:         Development/Toolchain
 Summary:       The GNU C Compiler and Support Files
 License:        GPL-3.0+
 
@@ -230,7 +226,6 @@ gcc-obj-c++.
 %package -n libffi%{libffi_sover}%{libffi_suffix}
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -243,7 +238,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -256,7 +250,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -270,7 +263,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover} >= %{version}-%{release}
 
 %description -n libffi48-devel
@@ -278,7 +270,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-32bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-32bit >= %{version}-%{release}
 
 %description -n libffi48-devel-32bit
@@ -286,7 +277,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-64bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-64bit >= %{version}-%{release}
 
 %description -n libffi48-devel-64bit
@@ -295,7 +285,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc48-testresults
 Summary:      Testsuite results
 License:       SUSE-Public-Domain
-Group:        Development/Languages/C and C++
 
 %description -n gcc48-testresults
 Results from running the gcc and target library testsuites.
@@ -412,7 +401,7 @@ Results from running the gcc and target library testsuites.
 
 
 %prep
-%setup -q -n gcc-%{gcc_version}%{snapshot_date}
+%setup -q -n gcc-%{version}
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -624,10 +613,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %endif
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
-       --with-tune=cortex-a9 \
-       --with-float=hard \
-       --with-abi=aapcs-linux \
-       --with-fpu=vfpv3-d16 \
+       --with-tune=cortex-a8 \
+       --with-float=softfp \
+       --with-fpu=vfpv3 \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"