Update to 4.8.2.
[platform/upstream/gcc48.git] / packaging / libffi48.spec
index ede8c83..37532ec 100644 (file)
@@ -24,7 +24,7 @@
 
 %define quadmath_arch %ix86 x86_64 ia64
 %define tsan_arch x86_64
-%define asan_arch x86_64 %ix86 ppc ppc64
+%define asan_arch x86_64 %ix86 ppc ppc64 %arm
 %define itm_arch x86_64 %ix86 %arm ppc ppc64
 %define atomic_arch x86_64 %ix86 %arm ppc ppc64 s390 s390x
 
@@ -33,9 +33,9 @@
 %define build_libjava 0
 
 %define build_cp 1
-%define build_fortran !0%{?building_libjava:1}%{?building_libffi:1}
-%define build_objc !0%{?building_libjava:1}%{?building_libffi:1}
-%define build_objcp !0%{?building_libjava:1}%{?building_libffi:1}
+%define build_fortran 0%{?building_libjava:1}%{?building_libffi:1}
+%define build_objc 0%{?building_libjava:1}%{?building_libffi:1}
+%define build_objcp 0%{?building_libjava:1}%{?building_libffi:1}
 %define build_with_mudflap 0
 
 %if %{build_objcp}
@@ -173,11 +173,9 @@ BuildRequires: gdb
 %define biarch_targets x86_64 s390x powerpc64 powerpc sparc sparc64
 
 URL:          http://gcc.gnu.org/
-Version: 4.8.1
+Version: 4.8.2
 Release:      1
-%define gcc_version %(echo %version | sed 's/_.*//')
-%define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
-%define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
+%define gcc_dir_version 4.8
 %define binsuffix -4.8
 
 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
@@ -205,14 +203,14 @@ Suggests: gcc48-info gcc48-locale
 %endif
 
 BuildRoot:     %{_tmppath}/%{name}-%{version}-build
-Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
+Source:                gcc-%{version}.tar.bz2
 Source1:       change_spec
 Source3:       gcc48-rpmlintrc
 Source4:       ecj.jar
 Source6:       baselibs.conf
 
 
-Group:         Development/Languages/C and C++
+Group:         Development/Toolchain
 Summary:       The GNU C Compiler and Support Files
 License:        GPL-3.0+
 
@@ -226,7 +224,6 @@ gcc-obj-c++.
 %package -n libffi%{libffi_sover}%{libffi_suffix}
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -239,7 +236,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -252,7 +248,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -266,7 +261,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover} >= %{version}-%{release}
 
 %description -n libffi48-devel
@@ -274,7 +268,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-32bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-32bit >= %{version}-%{release}
 
 %description -n libffi48-devel-32bit
@@ -282,7 +275,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-64bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-64bit >= %{version}-%{release}
 
 %description -n libffi48-devel-64bit
@@ -291,7 +283,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc48-testresults
 Summary:      Testsuite results
 License:       SUSE-Public-Domain
-Group:        Development/Languages/C and C++
 
 %description -n gcc48-testresults
 Results from running the gcc and target library testsuites.
@@ -408,7 +399,7 @@ Results from running the gcc and target library testsuites.
 
 
 %prep
-%setup -q -n gcc-%{gcc_version}%{snapshot_date}
+%setup -q -n gcc-%{version}
 
 
 # We are configuring ppc as ppc64 but with switched multilibs.  Adjust
@@ -560,6 +551,9 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --disable-plugin \
        --with-bugurl="http://bugs.tizen.org/" \
        --with-pkgversion="Tizen" \
+%if !%{build_fortran}
+       --disable-libquadmath \
+%endif
 %if !%{build_libjava}
         --disable-libgcj \
 %else
@@ -582,9 +576,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
        --enable-linker-build-id \
 %if 0%{?gcc_target_arch:1}
 %if 0%{?gcc_icecream:1}
-       --with-build-sysroot=/ \
-       --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
-       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
+       --with-sysroot=/ \
+       --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/include/c++/%{gcc_dir_version} \
        --enable-linux-futex \
 %endif
 %if 0%{?canonical_target:1}
@@ -620,10 +613,10 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %endif
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
-       --with-tune=cortex-a9 \
-       --with-float=hard \
-       --with-abi=aapcs-linux \
-       --with-fpu=vfpv3-d16 \
+       --with-tune=cortex-a8 \
+       --with-float=softfp \
+       --with-fpu=vfpv3 \
+       --with-mode=thumb \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"