set thumb as as default option for armv7l-gcc because thumb becomes default since...
[platform/upstream/gcc48.git] / packaging / libffi48.spec
index a8e856d..054ace5 100644 (file)
@@ -175,9 +175,7 @@ BuildRequires: gdb
 URL:          http://gcc.gnu.org/
 Version: 4.8.1
 Release:      1
-%define gcc_version %(echo %version | sed 's/_.*//')
-%define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
-%define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
+%define gcc_dir_version 4.8
 %define binsuffix -4.8
 
 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
@@ -212,7 +210,7 @@ Source4:    ecj.jar
 Source6:       baselibs.conf
 
 
-Group:         Development/Languages/C and C++
+Group:         Development/Toolchain
 Summary:       The GNU C Compiler and Support Files
 License:        GPL-3.0+
 
@@ -226,7 +224,6 @@ gcc-obj-c++.
 %package -n libffi%{libffi_sover}%{libffi_suffix}
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -239,7 +236,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-32bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -252,7 +248,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 Summary:      Foreign Function Interface library
 License:        BSD-3-Clause
-Group:        Development/Languages/C and C++
 
 %description -n libffi%{libffi_sover}%{libffi_suffix}-64bit
 A foreign function interface is the popular name for the interface that allows code written in one language to call code written in another language.
@@ -266,7 +261,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover} >= %{version}-%{release}
 
 %description -n libffi48-devel
@@ -274,7 +268,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-32bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-32bit >= %{version}-%{release}
 
 %description -n libffi48-devel-32bit
@@ -282,7 +275,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n libffi48-devel-64bit
 Summary:      Foreign Function Interface library development files
 License:        BSD 3-Clause
-Group:        Development/Languages/C and C++
 Requires: libffi%{libffi_sover}-64bit >= %{version}-%{release}
 
 %description -n libffi48-devel-64bit
@@ -291,7 +283,6 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc48-testresults
 Summary:      Testsuite results
 License:       SUSE-Public-Domain
-Group:        Development/Languages/C and C++
 
 %description -n gcc48-testresults
 Results from running the gcc and target library testsuites.
@@ -620,9 +611,10 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS $GCJ_EXTRA_FLAGS" \
 %endif
 %if "%{TARGET_ARCH}" == "armv7l" 
        --with-arch=armv7-a \
-       --with-tune=cortex-a9 \
-    --with-float=soft \
-       --with-fpu=vfpv3-d16 \
+       --with-tune=cortex-a8 \
+       --with-float=softfp \
+       --with-fpu=vfpv3 \
+       --with-mode=thumb \
        --disable-sjlj-exceptions \
 %endif
 %if  "%{TARGET_ARCH}" == "armv7hl"