cleanup spec
[platform/upstream/gcc48.git] / packaging / libffi47.spec
index 6b9ab69..7b15cbb 100644 (file)
 %define build_ada 0
 %endif
 
-%define quadmath_arch %ix86 x86_64 ia64
+%define quadmath_arch %ix86 x86_64 
 
 # We don't want to build java
-%ifarch mips
-%define build_java 0
-%define build_libjava 0
-%else
 %define build_java 1
 %define build_libjava 0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
-%endif
 
 %define build_cp 1
 %define build_fortran 1
@@ -73,9 +68,6 @@ BuildRequires: unzip
 %if 0%{?building_libffi:1}
 BuildRequires: pkg-config
 %endif
-%ifarch ia64
-BuildRequires: libunwind-devel
-%endif
 %if 0%{?run_tests:1}
 BuildRequires: dejagnu
 BuildRequires: expect
@@ -83,18 +75,8 @@ BuildRequires: gdb
 %endif
 
 # Define version number of libgcc_s
-%ifarch hppa
-%define libgcc_s 4
-%else
 %define libgcc_s 1
-%endif
-%ifarch ppc
-# We support building the nof libraries, but don't want this in the
-# regular rpms
 %define build_nof 0
-%else
-%define build_nof 0
-%endif
 
 %define separate_bi32 0
 %define separate_bi64 0
@@ -267,7 +249,7 @@ A foreign function interface is the popular name for the interface that allows c
 %package -n gcc47-testresults
 # GCC-TESTSUITE-DELETE-END
 Summary:      Testsuite results
-License:       SUSE-Public-Domain
+License:       Public-Domain
 Group:        Development/Languages/C and C++
 
 %description -n gcc47-testresults
@@ -608,12 +590,8 @@ TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
 %else
        --program-suffix=%{binsuffix} \
        --enable-linux-futex \
-%ifarch ia64
-       --with-system-libunwind \
-%else
        --without-system-libunwind \
 %endif
-%endif
 %if "%{TARGET_ARCH}" == "armv5tel"
        --with-arch=armv5te \
        --with-float=soft \
@@ -654,7 +632,7 @@ make stage1-bubble $PARALLEL
 make all-target-libffi $PARALLEL
 %else
 # Only run profiled bootstrap on archs where it works
-#%ifarch %ix86 x86_64 ppc ppc64 ia64
+#%ifarch %ix86 x86_64 
 #make profiledbootstrap-lean STAGE1_CFLAGS="-O -g" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
 #%else
 %ifarch %arm
@@ -824,9 +802,6 @@ crt32_list=$RPM_BUILD_ROOT%{versmainlibdirbi32}/crt*.o
 crt64_list=$RPM_BUILD_ROOT%{versmainlibdirbi64}/crt*.o
 %endif
 %endif
-for o in $crt_list $crt32_list $crt64_list; do
-  objcopy -R ".comment.SUSE.OPTs" $o
-done
 %endif
 
 %if 0%{?building_libjava:1}