Sync with the latest private repository
[apps/native/widget/widget.git] / packaging / libdynamicbox.spec
similarity index 69%
rename from packaging/liblivebox.spec
rename to packaging/libdynamicbox.spec
index 2f2bc87..61acda0 100644 (file)
@@ -1,17 +1,17 @@
 %bcond_with wayland
 
-Name: liblivebox
-Summary: Livebox development library
-Version: 0.7.4
+Name: libdynamicbox
+Summary: Dynamicbox development library
+Version: 1.0.0
 Release: 1
-Group: HomeTF/Livebox
+Group: HomeTF/DynamicBox
 License: Flora
 Source0: %{name}-%{version}.tar.gz
 Source1001: %{name}.manifest
 BuildRequires: cmake, gettext-tools, coreutils
 BuildRequires: pkgconfig(dlog)
-BuildRequires: pkgconfig(livebox-service)
-BuildRequires: pkgconfig(provider)
+BuildRequires: pkgconfig(dynamicbox_service)
+BuildRequires: pkgconfig(dynamicbox_provider)
 BuildRequires: pkgconfig(ecore)
 BuildRequires: pkgconfig(evas)
 BuildRequires: pkgconfig(elementary)
@@ -26,15 +26,15 @@ ExclusiveArch:
 %endif
 
 %description
-Library for the development of a livebox
+Library for the development of a dynamicbox 
 
 %package devel
-Summary: Livebox development library (dev)
+Summary: Dynamic Box development library (dev)
 Group: Development/Libraries
 Requires: %{name} = %{version}-%{release}
 
 %description devel
-Header & Package configuration files for livebox development
+Header & Package configuration files for dynamicbox development
 
 %prep
 %setup -q
@@ -53,14 +53,6 @@ export CXXFLAGS="${CXXFLAGS} -DTIZEN_ENGINEER_MODE"
 export FFLAGS="${FFLAGS} -DTIZEN_ENGINEER_MODE"
 %endif
 
-%if "%{_repository}" == "wearable"
-export WEARABLE=On
-export MOBILE=Off
-%elseif "%{_repository}" == "mobile"
-export WEARABLE=Off
-export MOBILE=On
-%endif
-
 %if %{with wayland}
 export WAYLAND_SUPPORT=On
 export X11_SUPPORT=Off
@@ -69,7 +61,7 @@ export WAYLAND_SUPPORT=Off
 export X11_SUPPORT=On
 %endif
 
-%cmake . -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT} -DMOBILE=${MOBILE} -DWEARABLE=${WEARABLE}
+%cmake . -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
 make %{?jobs:-j%jobs}
 
 %install
@@ -77,19 +69,19 @@ rm -rf %{buildroot}
 %make_install
 mkdir -p %{buildroot}/%{_datarootdir}/license
 
-%post -n liblivebox -p /sbin/ldconfig
-%postun -n liblivebox -p /sbin/ldconfig
+%post -n %{name} -p /sbin/ldconfig
+%postun -n %{name} -p /sbin/ldconfig
 
-%files -n liblivebox
-%manifest %{name}.manifest
+%files -n %{name}
 %defattr(-,root,root,-)
+%manifest %{name}.manifest
 %{_libdir}/*.so*
 %{_datarootdir}/license/*
 
 %files devel
-%manifest %{name}.manifest
 %defattr(-,root,root,-)
-%{_includedir}/livebox/livebox.h
+%manifest %{name}.manifest
+%{_includedir}/dynamicbox/dynamicbox.h
 %{_libdir}/pkgconfig/*.pc
 
 # End of a file