video: Add tests for ds_tizen_video
[platform/core/uifw/libds-tizen.git] / packaging / libds-tizen.spec
index 65b6c33..19837eb 100644 (file)
@@ -16,6 +16,8 @@ BuildRequires:  pkgconfig(tizen-extension-server)
 BuildRequires:  pkgconfig(tizen-extension-client)
 BuildRequires:  pkgconfig(tizen-launch-server)
 BuildRequires:  pkgconfig(tizen-launch-client)
+BuildRequires:  pkgconfig(text-server)
+BuildRequires:  pkgconfig(text-client)
 BuildRequires:  pkgconfig(input-method-server)
 BuildRequires:  pkgconfig(input-method-client)
 BuildRequires:  pkgconfig(pixman-1)
@@ -30,10 +32,14 @@ BuildRequires:  pkgconfig(tizen-dpms-server)
 BuildRequires:  pkgconfig(tizen-dpms-client)
 BuildRequires:  pkgconfig(tizen-surface-server)
 BuildRequires:  pkgconfig(tizen-surface-client)
+BuildRequires : pkgconfig(tizen-hwc-server)
+BuildRequires : pkgconfig(tizen-hwc-client)
 BuildRequires:  pkgconfig(cynara-client)
 BuildRequires:  pkgconfig(cynara-session)
 BuildRequires:  pkgconfig(libsmack)
 BuildRequires:  pkgconfig(gmock)
+BuildRequires:  pkgconfig(scaler-server)
+BuildRequires:  pkgconfig(scaler-client)
 
 %description
 Wayland Compositor Library for Tizen
@@ -263,6 +269,21 @@ Group:   Development/Libraries
 %description embedded-compositor-devel
 Development package for tizen embedded compositor
 
+## libds-tizen-text-input
+%package text-input
+Summary: Library for tizen text-input
+Group:   Development/Libraries
+
+%description text-input
+Library for tizen text-input
+
+%package text-input-devel
+Summary: Development package for tizen text-input
+Group:   Development/Libraries
+
+%description text-input-devel
+Development package for tizen text-input
+
 ## libds-tizen-input-method
 %package input-method
 Summary: Library for tizen input-method
@@ -278,6 +299,81 @@ Group:   Development/Libraries
 %description input-method-devel
 Development package for tizen input-method
 
+## libds-tizen-hwc
+%package hwc
+Summary: Library for tizen hwc
+Group:   Development/Libraries
+
+%description hwc
+Library for tizen hwc
+
+%package hwc-devel
+Summary: Development package for tizen hwc
+Group:   Development/Libraries
+
+%description hwc-devel
+Development package for tizen hwc
+
+## libds-tizen-policy
+%package policy
+Summary: Library for tizen policy
+Group:   Development/Libraries
+
+%description policy
+Library for tizen policy
+
+%package policy-devel
+Summary: Development package for tizen policy
+Group:   Development/Libraries
+
+%description policy-devel
+Development package for tizen policy
+
+## libds-tizen-screenshooter
+%package screenshooter
+Summary: Library for tizen screenshooter
+Group:   Development/Libraries
+
+%description screenshooter
+Library for tizen screenshooter
+
+%package screenshooter-devel
+Summary: Development package for tizen screenshooter
+Group:   Development/Libraries
+
+%description screenshooter-devel
+Development package for tizen screenshooter
+
+## libds-tizen-scaler
+%package scaler
+Summary: Library for tizen scaler
+Group:   Development/Libraries
+
+%description scaler
+Library for tizen scaler
+
+%package scaler-devel
+Summary: Development package for tizen scaler
+Group:   Development/Libraries
+
+%description scaler-devel
+Development package for tizen scaler
+
+## libds-tizen-video
+%package video
+Summary: Library for tizen video
+Group:   Development/Libraries
+
+%description video
+Library for tizen video
+
+%package video-devel
+Summary: Development package for tizen video
+Group:   Development/Libraries
+
+%description video-devel
+Development package for tizen video
+
 %prep
 %setup -q
 cp %{SOURCE1001} .
@@ -522,6 +618,21 @@ ninja -C builddir install
 %{_libdir}/libds-tizen-embedded-compositor.so
 %{_bindir}/libds-tizen-embedded-compositor-tests
 
+%files text-input
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_libdir}/libds-tizen-text-input.so.*
+
+%files text-input-devel
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_includedir}/libds-tizen/text_input.h
+%{_libdir}/pkgconfig/libds-tizen-text-input.pc
+%{_libdir}/libds-tizen-text-input.so
+%{_bindir}/libds-tizen-text-input-tests
+
 %files input-method
 %manifest %{name}.manifest
 %defattr(-,root,root,-)
@@ -536,3 +647,79 @@ ninja -C builddir install
 %{_libdir}/pkgconfig/libds-tizen-input-method.pc
 %{_libdir}/libds-tizen-input-method.so
 %{_bindir}/libds-tizen-input-method-tests
+%{_bindir}/libds-tizen-input-method-manager-tests
+
+%files hwc
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_libdir}/libds-tizen-hwc.so*
+
+%files hwc-devel
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_includedir}/libds-tizen/hwc.h
+%{_libdir}/pkgconfig/libds-tizen-hwc.pc
+%{_libdir}/libds-tizen-hwc.so*
+%{_bindir}/libds-tizen-hwc-tests
+
+%files policy
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_libdir}/libds-tizen-policy.so.*
+
+%files policy-devel
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_includedir}/libds-tizen/policy.h
+%{_libdir}/pkgconfig/libds-tizen-policy.pc
+%{_libdir}/libds-tizen-policy.so
+%{_bindir}/libds-tizen-policy-tests
+
+%files screenshooter
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_libdir}/libds-tizen-screenshooter.so.*
+
+%files screenshooter-devel
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_includedir}/libds-tizen/screenshooter.h
+%{_libdir}/pkgconfig/libds-tizen-screenshooter.pc
+%{_libdir}/libds-tizen-screenshooter.so
+%{_bindir}/libds-tizen-screenshooter-tests
+
+%files scaler
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_libdir}/libds-tizen-scaler.so.*
+
+%files scaler-devel
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_includedir}/libds-tizen/scaler.h
+%{_libdir}/pkgconfig/libds-tizen-scaler.pc
+%{_libdir}/libds-tizen-scaler.so
+%{_bindir}/libds-tizen-scaler-tests
+
+%files video
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_libdir}/libds-tizen-video.so.*
+
+%files video-devel
+%manifest %{name}.manifest
+%defattr(-,root,root,-)
+%license LICENSE
+%{_includedir}/libds-tizen/video.h
+%{_libdir}/pkgconfig/libds-tizen-video.pc
+%{_libdir}/libds-tizen-video.so
+%{_bindir}/libds-tizen-video-tests