Release 0.1.54.9
[platform/core/security/key-manager.git] / packaging / key-manager.spec
index 1756d16..71b34fe 100644 (file)
@@ -2,6 +2,7 @@
 %global watchdog_timeout_sec 60
 %global watchdog_notify_sec  20
 %global tz_backend_enabled %{?tz_backend:%tz_backend}%{!?tz_backend:OFF}
+%global se_backend_enabled %{?se_backend:%se_backend}%{!?se_backend:OFF}
 %{!?build_type:%global build_type RELEASE}
 %global coverage_only 0
 %if %{build_type} == COVERAGE_ONLY
@@ -11,7 +12,7 @@
 
 Name:       key-manager
 Summary:    Central Key Manager and utilities
-Version:    0.1.43
+Version:    0.1.54.9
 Release:    1
 Group:      Security/Secure Storage
 License:    Apache-2.0 and BSD-3-Clause
@@ -47,6 +48,9 @@ BuildRequires: key-manager-ta-devel
 BuildRequires: key-manager-ta-serialization-devel
 BuildRequires: pkgconfig(tef-libteec)
 %endif
+%if %{se_backend_enabled} == ON
+BuildRequires: pkgconfig(key-manager-se-backend)
+%endif
 Requires: libkey-manager-common = %{version}-%{release}
 %if "%{build_type}" == "COVERAGE"
 BuildRequires: lcov
@@ -177,11 +181,6 @@ Central Key Manager code coverage data
 %setup -q
 
 %build
-%if 0%{?sec_build_binary_debug_enable}
-    export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
-    export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
-%endif
-
 export LDFLAGS+="-Wl,--rpath=%{_libdir},-Bsymbolic-functions"
 
 %cmake . -DVERSION=%{version} \
@@ -214,6 +213,11 @@ export LDFLAGS+="-Wl,--rpath=%{_libdir},-Bsymbolic-functions"
 %else
         -DTZ_BACKEND_ENABLED=OFF \
 %endif
+%if %{se_backend_enabled} == ON
+        -DSE_BACKEND_ENABLED=ON \
+%else
+        -DSE_BACKEND_ENABLED=OFF \
+%endif
         -DUNIT_TESTS_DIR=%{unit_tests_dir} \
         -DMISC_DIR=%{misc_dir} \
         -DCOVERAGE_DIR=%{coverage_dir} \
@@ -389,6 +393,7 @@ fi
 %{bin_dir}/ckm_db_merge
 %{bin_dir}/ckm_generate_db
 %{bin_dir}/ckm_db_perf
+%{bin_dir}/ckm_enc_perf
 %misc_dir
 
 %endif