Merge "fix: the incorrect version of tarball generated by gbs export" into tizen
[platform/upstream/js.git] / packaging / js.spec
index caa2d9e..ad445f0 100644 (file)
@@ -52,7 +52,12 @@ you will need to install %{name}-devel.
 export MOZILLA_VERSION=%{version}
 cd js
 pushd src
-%configure --with-system-nspr --enable-threadsafe
+%ifarch aarch64
+export CPPFLAGS+=" -DENABLE_JIT=0 "
+export JIT_CONFIG_OPT="--disable-tracejit --disable-methodjit"
+%endif
+%configure --with-system-nspr --enable-threadsafe $JIT_CONFIG_OPT
+
 popd
 export BUILD_OPT=1
 %{__make} %{?_smp_mflags} -C src \