Apply -fvisibility to decrease binary size
[platform/core/uifw/ise-engine-sunpinyin.git] / packaging / ise-engine-sunpinyin.spec
index a337c16..e0b7ced 100755 (executable)
@@ -1,6 +1,6 @@
 Name:       ise-engine-sunpinyin
 Summary:    Chinese Pinyin ISE
-Version:    1.0.6
+Version:    1.0.9
 Release:    1
 Group:      Graphics & UI Framework/Input
 License:    LGPL-2.1+ and CDDL-1.0
@@ -27,6 +27,10 @@ This package contains Chinese Pinyin engine ISE header files and static librarie
 %setup -q
 
 %build
+export CFLAGS+=" -fvisibility=hidden"
+export CXXFLAGS+=" -fvisibility=hidden -fvisibility-inlines-hidden"
+export CPPFLAGS+=" -DEXPORTED=__attribute__\(\(visibility\(\\\"default\\\"\)\)\)"
+
 ./bootstrap
 %configure  --disable-static
 make %{?jobs:-j%jobs}