[Fix] Build issue for x86_64 architecture
[platform/upstream/iptables.git] / packaging / iptables.spec
index 4fcbb7b..edd3d30 100755 (executable)
@@ -1,7 +1,7 @@
 Name:          iptables
 Summary:       Tools for managing Linux kernel packet filtering capabilities
 Version:       1.6.1
-Release:       1
+Release:       2
 Group:         System/Network
 Source:                %{name}-%{version}.tar.gz
 URL:           http://www.netfilter.org
@@ -33,7 +33,7 @@ stable and may change with every new version. It is therefore unsupported.
 
 
 %build
-export CFLAGS+=" $RPM_OPT_FLAGS -Wall -Werror -O2 -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fPIE -pie -fno-strict-aliasing -Wno-unused-value"
+export CFLAGS+=" $RPM_OPT_FLAGS -Wall -Werror -O2 -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fPIE -pie -fno-strict-aliasing -Wno-unused-value -fPIC"
 export LDFLAGS+=" -Wl,-z,relro,--as-needed"
 
 %autogen.sh