Delete client callback for error response.
[platform/upstream/iotivity.git] / packaging / iotivity.spec
old mode 100755 (executable)
new mode 100644 (file)
index c213249..947b4f5
@@ -35,6 +35,7 @@ Source1002: %{name}-test.manifest
 # For Example
 %if %{RELEASE} == "True"
 %define build_mode release
+%define log_level INFO
 %else
 %define build_mode debug
 %endif
@@ -85,13 +86,13 @@ Source1002: %{name}-test.manifest
 %{!?RD_MODE: %define RD_MODE CLIENT}
 %{!?BLE_CUSTOM_ADV: %define BLE_CUSTOM_ADV False}
 %{!?BLE_DIVISION: %define BLE_DIVISION VD}
+%{!?DISABLE_BLE_SERVER: %define DISABLE_BLE_SERVER 0}
+%{!?MULTIPLE_OWNER: %define MULTIPLE_OWNER 1}
 %{!?BLE_TIZEN_30: %define BLE_TIZEN_30 True}
-%{!?MULTIPLE_OWNER: %define MULTIPLE_OWNER 0}
 
 BuildRequires:  expat-devel
 BuildRequires:  python, libcurl-devel
 BuildRequires:  scons
-BuildRequires:  openssl-devel
 BuildRequires:  boost-devel
 BuildRequires:  boost-thread
 BuildRequires:  boost-system
@@ -183,7 +184,9 @@ scons %{JOB} --prefix=%{_prefix} \
     BLE_CUSTOM_ADV=%{BLE_CUSTOM_ADV} \
     BLE_DIVISION=%{BLE_DIVISION} \
     BLE_TIZEN_30=%{BLE_TIZEN_30} \
+    DISABLE_BLE_SERVER=%{DISABLE_BLE_SERVER} \
     MULTIPLE_OWNER=%{MULTIPLE_OWNER} \
+    LOG_LEVEL=%{log_level} \
     #eol
 
 %install
@@ -264,7 +267,6 @@ mkdir -p %{ex_include_dir}/c_common
 
 # Install missed header files
 cp service/resource-encapsulation/include/*.h %{buildroot}%{_includedir}/service/resource-encapsulation
-cp service/resource-encapsulation/include/*.h %{buildroot}%{_includedir}/service/resource-encapsulation
 cp service/notification/include/*.h %{buildroot}%{_includedir}/service/notification
 cp service/notification/cpp-wrapper/common/*.h %{buildroot}%{_includedir}/service/notification
 cp service/notification/cpp-wrapper/provider/inc/*.h %{buildroot}%{_includedir}/service/notification