Providing build option to disable BLE server
[platform/upstream/iotivity.git] / packaging / iotivity.spec
index f5b7f60..764c963 100755 (executable)
@@ -86,6 +86,7 @@ Source1002: %{name}-test.manifest
 %{!?BLE_CUSTOM_ADV: %define BLE_CUSTOM_ADV False}
 %{!?BLE_DIVISION: %define BLE_DIVISION VD}
 %{!?BLE_TIZEN_30: %define BLE_TIZEN_30 True}
+%{!?DISABLE_BLE_SERVER: %define DISABLE_BLE_SERVER 0}
 %{!?MULTIPLE_OWNER: %define MULTIPLE_OWNER 1}
 
 BuildRequires:  expat-devel
@@ -183,6 +184,7 @@ scons %{JOB} --prefix=%{_prefix} \
     BLE_CUSTOM_ADV=%{BLE_CUSTOM_ADV} \
     BLE_DIVISION=%{BLE_DIVISION} \
     BLE_TIZEN_30=%{BLE_TIZEN_30} \
+    DISABLE_BLE_SERVER=%{DISABLE_BLE_SERVER} \
     MULTIPLE_OWNER=%{MULTIPLE_OWNER} \
     #eol