Exclude ASAN build until applying iotivity upstream patchset
[platform/upstream/iotivity.git] / packaging / iotivity.spec
index 54d09d1..01a20a4 100755 (executable)
@@ -164,6 +164,10 @@ cp %{SOURCE1001} ./%{name}-test.manifest
 %endif
 
 %build
+# Exclude ASAN build
+# After applying github patchset, we will remove this line
+%{?asan:/usr/bin/gcc-unforce-options}
+
 scons %{JOB} --prefix=%{_prefix} \
     ES_TARGET_ENROLLEE=%{ES_TARGET_ENROLLEE} \
     LIB_INSTALL_DIR=%{_libdir} \