Bump to icu 58.2
[platform/upstream/icu.git] / packaging / icu.spec
index adb1123..c09d559 100644 (file)
@@ -1,4 +1,3 @@
-
 %define run_tests 0
 %if %{run_tests}
     # check is defined off at .rpmmacros file.
@@ -6,11 +5,11 @@
 %endif
 
 Name:      icu
-Version:   58.1
+Version:   58.2
 Release:   1
 Summary:   International Components for Unicode
 Group:     System/Libraries
-License:   ICU and Unicode-TOU and BSD-3-Clause
+License:   ICU and Unicode-TOU and BSD-2.0
 URL:       http://www.icu-project.org/
 Source0:   %{name}-%{version}.tar.gz
 Source1001:    icu.manifest
@@ -18,32 +17,25 @@ BuildRequires: doxygen
 BuildRequires: autoconf
 
 %description
-ICU is a set of C and C++ libraries that provides robust and full-featured
-Unicode and locale support. The library provides calendar support, conversions
-for many character sets, language sensitive collation, date
-and time formatting, support for many locales, message catalogs
-and resources, message formatting, normalization, number and currency
-formatting, time zones support, transliteration, word, line and
-sentence breaking, etc.
-
-This package contains the Unicode character database and derived
-properties, along with converters and time zones data.
-
-This package contains the runtime libraries for ICU. It does
-not contain any of the data files needed at runtime and present in the
-`icu' and `icu-locales` packages.
+Tools and utilities for developing with icu.
 
 %package -n libicu
-Summary: International Components for Unicode (libraries)
+Summary: International Components for Unicode - libraries
 
 %description -n libicu
-ICU is a set of C and C++ libraries that provides robust and full-featured
-Unicode support. This package contains the runtime libraries for ICU. It does
-not contain any of the data files needed at runtime and present in the
-`icu' and `icu-locales` packages.
+The International Components for Unicode (ICU) libraries provide
+robust and full-featured Unicode services on a wide variety of
+platforms. ICU supports the most current version of the Unicode
+standard, and they provide support for supplementary Unicode
+characters (needed for GB 18030 repertoire support).
+As computing environments become more heterogeneous, software
+portability becomes more important. ICU lets you produce the same
+results across all the various platforms you support, without
+sacrificing performance. It offers great flexibility to extend and
+customize the supplied services.
 
 %package  -n libicu-devel
-Summary: International Components for Unicode (development files)
+Summary:  Development files for International Components for Unicode
 Requires: libicu = %{version}-%{release}
 Requires: pkgconfig
 
@@ -55,6 +47,9 @@ Includes and definitions for developing with icu.
 cp %{SOURCE1001} .
 
 %build
+export CFLAGS="$CFLAGS -D_TIZEN_FEATURE_"
+export CXXFLAGS="$CXXFLAGS -D_TIZEN_FEATURE_"
+
 cd source
 %configure --enable-static=no \
             --enable-renaming=no \
@@ -86,9 +81,11 @@ chmod +x %{buildroot}/%{_libdir}/lib*.so.*
 
 %files
 %manifest %{name}.manifest
+%license LICENSE
 
 %files -n libicu
 %manifest %{name}.manifest
+%license LICENSE
 %{_libdir}/*.so*
 %{_bindir}/derb
 %{_bindir}/genbrk
@@ -110,6 +107,7 @@ chmod +x %{buildroot}/%{_libdir}/lib*.so.*
 
 %files -n libicu-devel
 %manifest %{name}.manifest
+%license LICENSE
 %{_includedir}/unicode
 %{_libdir}/*.so
 %{_libdir}/pkgconfig/icu-*.pc