remove icu header dependencies from harfbuzz header
[platform/upstream/harfbuzz.git] / packaging / harfbuzz.spec
index 0fa6d90..f2d623d 100644 (file)
@@ -1,44 +1,42 @@
 Name:           harfbuzz
-Version:        0.9.3
-Release:        2.1
-License:        MIT
-# FIXME: graphite2 is not packaged / http://projects.palaso.org/projects/graphitedev
+Version:        2.4.0
+Release:        0
+License:        MIT and ISC
 Summary:        An OpenType text shaping engine
 Url:            http://www.freedesktop.org/wiki/Software/HarfBuzz
-Group:          Productivity/Text/Utilities
+Group:          Graphics/Font Management
 Source:         %{name}-%{version}.tar.bz2
 Source99:       baselibs.conf
+Source1001:    harfbuzz.manifest
 BuildRequires:  gcc-c++
-BuildRequires:  pkgconfig(cairo) >= 1.8.0
-BuildRequires:  pkgconfig(cairo-ft)
+#BuildRequires:  pkgconfig(cairo) >= 1.8.0
+#BuildRequires:  pkgconfig(cairo-ft)
 BuildRequires:  pkgconfig(freetype2) >= 2.3.8
 BuildRequires:  pkgconfig(glib-2.0) >= 2.16
 BuildRequires:  pkgconfig(gobject-2.0)
-#BuildRequires:  pkgconfig(graphite2)
 BuildRequires:  pkgconfig(gthread-2.0)
 BuildRequires:  pkgconfig(icu-uc)
-BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
 HarfBuzz is an OpenType text shaping engine.
 
 %package -n libharfbuzz
 Summary:        An OpenType text shaping engine
-Group:          System/Libraries
+Group:          Graphics/Font Management
 
 %description -n libharfbuzz
 HarfBuzz is an OpenType text shaping engine.
 
 %package tools
 Summary:        An OpenType text shaping engine -- Tools
-Group:          Productivity/Text/Utilities
+Group:          Graphics/Font Management
 
 %description tools
 HarfBuzz is an OpenType text shaping engine.
 
 %package devel
 Summary:        An OpenType text shaping engine -- Development Files
-Group:          Development/Libraries/C and C++
+Group:          Development/Libraries
 Requires:       libharfbuzz = %{version}
 
 %description devel
@@ -46,6 +44,8 @@ HarfBuzz is an OpenType text shaping engine.
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
+patch -p1 < %{_builddir}/%{name}-%{version}/patch/remove-icu-header-dependencies-from-harfbuzz-header.patch
 
 %build
 %configure \
@@ -54,24 +54,30 @@ make %{?_smp_mflags}
 
 %install
 %make_install
+rm -rf %{buildroot}/%{_datadir}/gtk-doc
 
 %post -n libharfbuzz -p /sbin/ldconfig
 
 %postun -n libharfbuzz -p /sbin/ldconfig
 
 %files -n libharfbuzz
+%manifest %{name}.manifest
 %defattr(-,root,root)
-%doc COPYING
-%{_libdir}/libharfbuzz.so.0*
+%license COPYING
+%{_libdir}/*.so.0*
 
 %files tools
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_bindir}/hb-ot-shape-closure
 %{_bindir}/hb-shape
-%{_bindir}/hb-view
+%{_bindir}/hb-subset
+#%{_bindir}/hb-view
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root)
 %{_includedir}/harfbuzz/
 %{_libdir}/*.so
-%{_libdir}/pkgconfig/harfbuzz.pc
+%{_libdir}/pkgconfig/*.pc
+%{_libdir}/cmake/harfbuzz/harfbuzz-config.cmake