Fixed continuous vibration along with system hang.
[platform/core/system/haptic-module-tizen.git] / packaging / haptic-module-tizen.spec
index 0d7437e..d2a6667 100644 (file)
@@ -2,15 +2,16 @@
 Name:       haptic-module-tizen
 Summary:    Haptic Module library
 Version:    0.1.0
-Release:    4
+Release:    9
 Group:      System/Libraries
 License:    APLv2
 Source0:    %{name}-%{version}.tar.gz
+Source1001:    haptic-module-tizen.manifest
 BuildRequires: cmake
 BuildRequires: pkgconfig(dlog)
 BuildRequires: pkgconfig(vconf)
 BuildRequires: pkgconfig(haptic-plugin)
-BuildRequires: pkgconfig(devman)
+BuildRequires: pkgconfig(device-node)
 
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
@@ -19,15 +20,16 @@ Requires(postun): /sbin/ldconfig
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 %build
 %if 0%{?simulator}
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DSIMULATOR=yes
+%cmake . -DSIMULATOR=yes
 %else
 %ifarch %{ix86}
 CFLAGS=`echo %{optflags} |sed 's/\-fexceptions//g'`
 %endif
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DSIMULATOR=no
+%cmake . -DSIMULATOR=no
 %endif
 make %{?jobs:-j%jobs}
 
@@ -40,4 +42,5 @@ rm -rf %{buildroot}
 %postun -p /sbin/ldconfig
 
 %files
+%manifest %{name}.manifest
 %{_libdir}/libhaptic-module.so