[effectv] Enable effectv for Media Editing FW
[platform/upstream/gst-plugins-good.git] / packaging / gst-plugins-good.spec
index f0f5beb..510716c 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:           gst-plugins-good
 Version:        1.16.2
-Release:        7
+Release:        31
 License:        LGPL-2.1+
 Summary:        GStreamer Streaming-Media Framework Plug-Ins
 Url:            http://gstreamer.freedesktop.org/
@@ -41,6 +41,7 @@ BuildRequires:  pkgconfig(libv4l2)
 %endif
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(gio-2.0)
+BuildRequires:  pkgconfig(libtbm)
 Requires:       gst-plugins-base >= 1.0.0
 Requires:       gstreamer >= 1.0.5
 
@@ -72,7 +73,7 @@ plugins not included in official Tizen images, which may be used for development
 export V=1
 NOCONFIGURE=1 ./autogen.sh
 export CFLAGS+=" \
-       -DTIZEN_FEATURE_V4L2SRC_SCAN_DEVICE_NODE\
+       -DTIZEN_FEATURE_V4L2SRC_AUTO_SCAN_DEVICE_NODE\
        -DTIZEN_FEATURE_V4L2SRC_SUPPORT_CAMERA_ID\
        -DTIZEN_FEATURE_V4L2VIDEO_ADJ_RANK\
        -DTIZEN_FEATURE_WAVPARSE_MODIFICATION\
@@ -80,14 +81,17 @@ export CFLAGS+=" \
        -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
        -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
        -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
-       -DTIZEN_FEATURE_GST_UPSTREAM\
+       -DTIZEN_FEATURE_GST_UPSTREAM_AVOID_BUILD_BREAK\
        -DTIZEN_FEATURE_RTSP_MODIFICATION\
        -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
        -DTIZEN_FEATURE_SOUP_MODIFICATION\
        -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
-       -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
        -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
+       -DTIZEN_FEATURE_AVIDEMUX_MODIFICATION\
        -DTIZEN_FEATURE_USE_LIBV4L2\
+       -DTIZEN_FEATURE_V4L2_ADDITIONAL_CID_SUPPORT\
+       -DTIZEN_FEATURE_V4L2_TBM_SUPPORT\
+       -D__TIZEN__\
        -fstack-protector-strong\
        -Wl,-z,relro\
        -D_FORTIFY_SOURCE=2"
@@ -98,7 +102,7 @@ export CFLAGS+=" \
 %if "%{tizen_profile_name}" != "tv"
        --with-libv4l2 \
 %endif
-       --disable-v4l2-probe\
+       --enable-v4l2-probe\
        --disable-gtk-doc\
        --with-gtk=3.0\
        --disable-monoscope\
@@ -112,16 +116,13 @@ export CFLAGS+=" \
        --disable-videobox\
        --disable-videomixer\
 %endif
-       --disable-effectv\
        --disable-alpha\
        --disable-auparse\
-       --disable-effectv\
        --disable-flx\
        --disable-goom\
        --disable-goom2k1\
        --disable-level\
        --disable-multipart\
-       --disable-smpte\
        --disable-spectrum\
        --disable-cutter\
        --disable-dtmf\
@@ -155,7 +156,7 @@ make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
 %{_libdir}/gstreamer-%{gst_branch}/libgstdebug.so
 # Not yet ported
 %{_libdir}/gstreamer-%{gst_branch}/libgstdeinterlace.so
-#%{_libdir}/gstreamer-%{gst_branch}/libgsteffectv.so
+%{_libdir}/gstreamer-%{gst_branch}/libgsteffectv.so
 
 #%{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
 
@@ -182,7 +183,7 @@ make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
 %{_libdir}/gstreamer-%{gst_branch}/libgstrtpmanager.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstrtsp.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstshapewipe.so
-#%{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstspectrum.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstspeex.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstudp.so
@@ -211,6 +212,7 @@ make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
 %{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
 %{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
 #%{_libdir}/gstreamer-%{gst_branch}/libgstdtmf.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so
 
 
 %files extra