avidemux: Fix coverity issue (Resource leak)
[platform/upstream/gst-plugins-good.git] / packaging / gst-plugins-good.spec
index 392cb7e..170555b 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:           gst-plugins-good
 Version:        1.16.2
-Release:        0
+Release:        11
 License:        LGPL-2.1+
 Summary:        GStreamer Streaming-Media Framework Plug-Ins
 Url:            http://gstreamer.freedesktop.org/
@@ -34,6 +34,7 @@ BuildRequires:  pkgconfig(xfixes)
 BuildRequires:  pkgconfig(xv)
 %endif
 
+BuildRequires:  pkgconfig(vpx)
 BuildRequires:  pkgconfig(zlib)
 %if "%{tizen_profile_name}" != "tv"
 BuildRequires:  pkgconfig(libv4l2)
@@ -70,24 +71,27 @@ plugins not included in official Tizen images, which may be used for development
 # warning: failed to load external entity "xml/plugin-video4linux2.xml"
 export V=1
 NOCONFIGURE=1 ./autogen.sh
-export CFLAGS+=" -DTIZEN_FEATURE_V4L2SRC_SCAN_DEVICE_NODE\
-                -DTIZEN_FEATURE_V4L2SRC_SUPPORT_CAMERA_ID\
-                -DTIZEN_FEATURE_V4L2VIDEO_ADJ_RANK\
-                -DTIZEN_FEATURE_WAVPARSE_MODIFICATION\
-                -DTIZEN_FEATURE_MP3PARSE_MODIFICATION\
-                -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
-                -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
-                -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
-                -DTIZEN_FEATURE_GST_UPSTREAM\
-                -DTIZEN_FEATURE_RTSP_MODIFICATION\
-                -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
-                -DTIZEN_FEATURE_SOUP_MODIFICATION\
-                -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
-                -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
-                -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
-                -fstack-protector-strong\
-                -Wl,-z,relro\
-                -D_FORTIFY_SOURCE=2"
+export CFLAGS+=" \
+       -DTIZEN_FEATURE_V4L2SRC_AUTO_SCAN_DEVICE_NODE\
+       -DTIZEN_FEATURE_V4L2SRC_SUPPORT_CAMERA_ID\
+       -DTIZEN_FEATURE_V4L2VIDEO_ADJ_RANK\
+       -DTIZEN_FEATURE_WAVPARSE_MODIFICATION\
+       -DTIZEN_FEATURE_MP3PARSE_MODIFICATION\
+       -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
+       -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
+       -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
+       -DTIZEN_FEATURE_GST_UPSTREAM\
+       -DTIZEN_FEATURE_RTSP_MODIFICATION\
+       -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
+       -DTIZEN_FEATURE_SOUP_MODIFICATION\
+       -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
+       -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
+       -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
+       -DTIZEN_FEATURE_AVIDEMUX_MODIFICATION\
+       -DTIZEN_FEATURE_USE_LIBV4L2\
+       -fstack-protector-strong\
+       -Wl,-z,relro\
+       -D_FORTIFY_SOURCE=2"
 %configure\
 %if ! 0%{?ENABLE_AALIB}
        --disable-aalib\
@@ -205,7 +209,8 @@ make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
 #%{_libdir}/gstreamer-%{gst_branch}/libgstcairo.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstsoup.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstflac.so
-#%{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
+%{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
 #%{_libdir}/gstreamer-%{gst_branch}/libgstdtmf.so