v4l2: Fix undefined reference error when libv4l2 is not used
[platform/upstream/gst-plugins-good.git] / packaging / gst-plugins-good.spec
index af4e3e6..041c917 100644 (file)
@@ -3,7 +3,7 @@
 
 Name:           gst-plugins-good
 Version:        1.16.2
-Release:        12
+Release:        30
 License:        LGPL-2.1+
 Summary:        GStreamer Streaming-Media Framework Plug-Ins
 Url:            http://gstreamer.freedesktop.org/
@@ -41,6 +41,7 @@ BuildRequires:  pkgconfig(libv4l2)
 %endif
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(gio-2.0)
+BuildRequires:  pkgconfig(libtbm)
 Requires:       gst-plugins-base >= 1.0.0
 Requires:       gstreamer >= 1.0.5
 
@@ -80,16 +81,17 @@ export CFLAGS+=" \
        -DTIZEN_FEATURE_AACPARSE_MODIFICATION\
        -DTIZEN_FEATURE_QTDEMUX_MODIFICATION\
        -DTIZEN_FEATURE_FLVDEMUX_MODIFICATION\
-       -DTIZEN_FEATURE_GST_UPSTREAM\
+       -DTIZEN_FEATURE_GST_UPSTREAM_AVOID_BUILD_BREAK\
        -DTIZEN_FEATURE_RTSP_MODIFICATION\
        -DTIZEN_FEATURE_GST_MUX_ENHANCEMENT\
        -DTIZEN_FEATURE_SOUP_MODIFICATION\
        -DTIZEN_FEATURE_RGVOLUME_MODIFICATION\
-       -DTIZEN_FEATURE_BASEPARSE_MODIFICATION\
        -DTIZEN_FEATURE_DISABLE_V4L2_DEPENDENCY\
        -DTIZEN_FEATURE_AVIDEMUX_MODIFICATION\
        -DTIZEN_FEATURE_USE_LIBV4L2\
        -DTIZEN_FEATURE_V4L2_ADDITIONAL_CID_SUPPORT\
+       -DTIZEN_FEATURE_V4L2_TBM_SUPPORT\
+       -D__TIZEN__\
        -fstack-protector-strong\
        -Wl,-z,relro\
        -D_FORTIFY_SOURCE=2"
@@ -100,7 +102,7 @@ export CFLAGS+=" \
 %if "%{tizen_profile_name}" != "tv"
        --with-libv4l2 \
 %endif
-       --disable-v4l2-probe\
+       --enable-v4l2-probe\
        --disable-gtk-doc\
        --with-gtk=3.0\
        --disable-monoscope\
@@ -123,7 +125,6 @@ export CFLAGS+=" \
        --disable-goom2k1\
        --disable-level\
        --disable-multipart\
-       --disable-smpte\
        --disable-spectrum\
        --disable-cutter\
        --disable-dtmf\
@@ -184,7 +185,7 @@ make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
 %{_libdir}/gstreamer-%{gst_branch}/libgstrtpmanager.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstrtsp.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstshapewipe.so
-#%{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstsmpte.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstspectrum.so
 #%{_libdir}/gstreamer-%{gst_branch}/libgstspeex.so
 %{_libdir}/gstreamer-%{gst_branch}/libgstudp.so
@@ -213,6 +214,7 @@ make %{?_smp_mflags} CFLAGS+="-Wno-error" CXXFLAGS+="-Wno-error"
 %{_libdir}/gstreamer-%{gst_branch}/libgstvpx.so
 %{_datadir}/gstreamer-%{gst_branch}/presets/GstVP8Enc.prs
 #%{_libdir}/gstreamer-%{gst_branch}/libgstdtmf.so
+%{_libdir}/gstreamer-%{gst_branch}/libgstimagefreeze.so
 
 
 %files extra